2 Replies Latest reply on May 19, 2008 8:20 PM by Wesley Moore

    Can't install AIR Apps

    Wesley Moore
      I've tried installing a couple AIR apps, and I get the same error each time:

      quote:

      Sorry, an error has occurred

      The application could not be installed. Try installing it again. If the problem persists, contact the application author. Error# 3003


      The AIR runtime installed ok:

      quote:

      Performing runtime install
      UI SWF load is complete
      UI initialized
      enter confirming
      Installation type: new
      stateInstalling: enter install
      Scheduling runtime installation operations
      Beginning runtime installation
      Beginning install
      Installing C:\DOCUME~1\wmoore\LOCALS~1\Temp\AIRD5.tmp\setup.msi
      Execution complete; beginning commit phase
      Commit complete


      The appinstall.log for twhirl says:

      quote:

      Starting app install of file:///C:/Documents%20and%20Settings/wmoore/Desktop/Dow
      nloads/twhirl-0.8.1.air
      UI SWF load is complete
      UI initialized
      Converting to C:\Documents and Settings\wmoore\Local Settings\Temp\flaED.tmp
      Conversion is complete
      AIR file is bound to version 1.0
      app id de.makesoft.twhirl
      application is bound to this version of the runtime
      Application is installed? false
      Waiting for user confirmation
      User confirmed action: install
      Starting install
      Destination for installed application is C:\Program Files
      Beginning install
      Installing C:\Documents and Settings\wmoore\Local Settings\Temp\flaED.tmp\setup.
      msi
      Execution complete; beginning commit phase
      Commit complete
      stateInstalling: [ErrorEvent type="error" bubbles=false cancelable=false eventPh
      ase=2 text="Error #3003" errorID=3003]
      Starting cleanup
      Installation exited


      System is WinXP Pro SP2, I do not have Admin rights on this machine.