3 Replies Latest reply on Feb 24, 2012 2:35 PM by GoodNewsJim

    trace stops working

    2ShoesLoose

      for reasons that are not apparent, the trace function will stop working.

       

      I am running in debug mode and I always see the usual sets of output:

           [SWF] Volumes:DATA:Flex Projects: .... etc

       

      I have re-installed both the Flash Player and the Debugger ... and yet this problem continues to appear.

       

      The most consistant method I've found for restoring the trace function is to quit Flash Builder, and then the first thing I do after reopening it is to Project/Clean.

       

      I may have to repeat this process a few times, but eventually it works.

        • 1. Re: trace stops working
          eprevot123

          Are you sure that the application that is launched in the browser is really the application you just updated ?

          I mean it happens the browser loads a cached application so if you add trace, it won't display it because it is still executing the old application.

          You see it in debug mode when you try to set a breakpoints and it says "no executable code here" or if the debug holds at some blank line.

          1 person found this helpful
          • 2. Re: trace stops working
            2ShoesLoose Level 1

            no ... than'ts not it.

            It will occur even when the previous time I ran the pgm it was in debug mode and tracing stmts, so if anything is cached and replaying, then it would be one that worked.

            I have yet to identify anything that causes the trace to stop functioning, but it will suddenly stop and I need to go throught the proceedure describe above to get it working again.

            Thanks for the suggestion though, I hadn't considered that before.

            • 3. Re: trace stops working
              GoodNewsJim Level 1

              There are a few things which can cause trace to stop working.  I had this problem a year and a half ago.  Do some googling for it.