10 Replies Latest reply on Feb 24, 2012 5:54 AM by witha_y

    Volume Label syntax error

    witha_y

      While trying to compile after making edits I received the following prompt:

       

      Syntax1.jpg

       

       

      As a result it is causing the system to close out on me.

       

      I've tried removing the .cpd file and compiling again: no results

      It took me a while to locate (using Version Control) but I believe it's referring the the folder below:

       

       

      Syntax2.jpg

       

      I tried to edit in Notepad to remove the highlighted text above then once again removed the .cpd file then attempted to open the project again to no avail. Prior to this last step I was unable to even open the project.  It will allow me now to open but I continue to get the same prompt and loop.

       

      Please help.  I'm a bit of a novice with this program.

        • 1. Re: Volume Label syntax error
          Jeff_Coatsworth Adobe Community Professional & MVP

          Whoa! That's got way too much stuff in it for a valid path - you need to get back to basics. Your project should be in a c:\projects\[project_name]\ folder. Keep the name simple - no spaces or weird characters.

          • 2. Re: Volume Label syntax error
            Anjaneai Srivastava Adobe Employee

            Hi,

             

            In addition to what Jeff added, which totally is a valid point.

            Looking at a glance to the CSS, I notice one anomaly, there is no corresponding closing tag (</name>) for V.2 2/22/2012 ldamour . I guess may be you removed that while editing manully??

             

            If not, It's worth a try.

             

            What is the SSL oputput you are using, try checking the compilation, for any other out put too!

             

            Thanks,

            Anjaneai

            • 3. Re: Volume Label syntax error
              witha_y Level 1

              The project was inherited, I had no control over the inital set up.  We've been using this (project/filename) for years without issue. 

              • 4. Re: Volume Label syntax error
                Captiv8r Adobe Community Professional & MVP

                Hi Anjaneai

                 

                I think the closing tag is present. It appears to have wrapped to the next line.

                 

                Cheers... Rick

                 

                Helpful and Handy Links

                Captivate Wish Form/Bug Reporting Form

                Adobe Certified Captivate Training

                SorcerStone Blog

                Captivate eBooks

                • 5. Re: Volume Label syntax error
                  witha_y Level 1

                  The output is a .chm file.  I just tried compiling a Flash file and received the same prompt.   The project is saved on a server, we have two authors and use Versin Control.  Yesterday,after this began to occur I asked the other RH user to open & compile the project to determine results.  She did not receive this prompt.  I've been referring to some of the details in Source Control in attempt to determine what happened and when.  This issue occured after I I made one edit to a file (which appear to be okay) then I moved a few ancillary files into folders from the Project Manager window.  This seems to be part of the issue.

                   

                  (I did mention that I'm a novice at this so you'll have to forgive that I won't be as technical in my jargon.)

                   

                  I reviewed every folder for continuity/format.  This folder is the only one that appears to list a <folder name within a folder name/>:

                   

                  <folder>

                  <name>v.2    2/22/12   ldamour   </name>

                          <name>Compliance,</name>

                  </folder>

                   

                  The remaining all have one file name within a folder.  The edit I've attempted is to remove the reference to the file name <name>v.2    2/22/12   ldamour   </name>.  I'm unable to determine what it is referring to.  

                   

                  Syntax5.jpg

                   

                   

                   

                  There is, however, two additional folders withing the "Compliance" folder.  This scenario does not exists in any other folder. 

                  Syntax6.jpg

                   

                  I must also admit that I'm not sure which of the following options is the best selection when upon receiving this prompt.  I've tried it several times, once selecting "Leave" the ohter, 'Replace'.  Neither corrected my issue.  I don't know what to expect with 'Manual Merge'. I also don't want to end up corrupting the project so that the other user will end up with these same prompts.  

                  Syntax4.jpg

                  • 6. Re: Volume Label syntax error
                    Anjaneai Srivastava Adobe Employee

                    lol ! Right Rick! Feeling like stupid at my advise now!

                    • 7. Re: Volume Label syntax error
                      Captiv8r Adobe Community Professional & MVP

                      Nah, don't beat yourself up.

                       

                      NONE of us are immune from mistakes and oversights! That's why extra eyes on something is always helpful!

                       

                      We appreciate your pitching in to help with things!

                       

                      Cheers... Rick

                       

                      Helpful and Handy Links

                      RoboHelp Wish Form/Bug Reporting Form

                      Begin learning RoboHelp HTML 7, 8 or 9 within the day!

                      Adobe Certified RoboHelp HTML Training

                      SorcerStone Blog

                      RoboHelp eBooks

                      • 8. Re: Volume Label syntax error
                        witha_y Level 1

                        this is the history from Source Control:

                         

                        Syntax7.jpg

                        • 9. Re: Volume Label syntax error
                          Amebr Level 4

                          The read-write message means the file was modified but not checked out of source control, or was checked out after the change was made, and source control is telling you  it can't see what it expects to see.

                           

                          So I'd undo the checkout (if it is), get the latest c.fpj file from source control (you might need to tick some checkboxes to force the latest file to actually be downloaded - not sure if this applies to RoboSource but thought I'd mention the possibility), check it out, then make the change to delete the "v.2" folder reference again.

                           

                          You definitely can't see a "v.2..." folder either in Windows Explorer or in RoboSourceControl?

                           

                          Amebr

                          • 10. Re: Volume Label syntax error
                            witha_y Level 1

                            Hi Amebr,

                            No, I definitely could not see a v.2 folder in either.  I even tried scanning for the file name to no avail.  While reviewing RoboSourceControl I also noticed that a lot of the files that should have been in the 'compliance' folder were now hidden.  Not sure what is going on. 

                             

                            I opted to rollback the version to the previous Check-in as a time saving gesture.  It will take less time to re-edit the few documents than to spend more time torubleshooting.  However, I'm printing out your suggestions for future reference.

                             

                            thank you for your help.