14 Replies Latest reply on Apr 16, 2018 5:11 PM by paulh19868029

    “Suite Product Activation Needed” (Acrobat Pro 9.5.0)

    acceptmydangscreenname Level 1

      Like several people have on this forum, I upgraded to Lion a few weeks ago with no issues, but trying to launch Acrobat Pro today resulted in this:


      Screen Shot 2012-02-24 at 15.21.38.png

      I've searched the forii, tried several possible solutions, and all have met with failure so far. I'm running OS X 10.7.3, and the CS5 suite; the version of Acrobat Pro is ostensibly 9.5.0. Is there anything else I can provide that would help turn this around quickly?




      (P.S. Excuse the screen name. It wasn't accepting my usual one, nor a formal name, and that's what I chose in exasperation—which, of course, it took and now won't let me change.)

        • 1. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
          acceptmydangscreenname Level 1

          I should note that I've tried the cache.db -> cache.old rename, I've tried downloading and running the License Recovery tool (which basically generated tons of error messages to the console, consisting of nothing but endless copies of this:


          2012/02/24 4:30:50.096 PM [0x0-0x18da8d9].LicenseRecover: Please choose a language:

          2012/02/24 4:30:50.096 PM [0x0-0x18da8d9].LicenseRecover:           e: English

          2012/02/24 4:30:50.096 PM [0x0-0x18da8d9].LicenseRecover:           j: Japanese (日本語)

          2012/02/24 4:30:50.096 PM [0x0-0x18da8d9].LicenseRecover:

          2012/02/24 4:30:50.096 PM [0x0-0x18da8d9].LicenseRecover: >: "" is not a valid response. Please enter one of "e", "j"

          2012/02/24 4:30:50.096 PM [0x0-0x18da8d9].LicenseRecover: *** process 97542 exceeded 500 log message per second limit  -  remaining messages this second discarded ***


          and I've tried a few other things, but nothing so far has changed anything (nor has it broken anything).

          • 2. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
            dave_m_k Adobe Employee

            Good day Ken,


            I'm sorry to hear you're having trouble.  What happened after you launched another application within the Suite, such as Photoshop, then re-launched Acrobat?


            Kind regards,


            Adobe Systems

            • 3. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
              acceptmydangscreenname Level 1

              Same thing, I'm afraid. I tried Photoshop, Illustrator, and InDesign, just to be sure.

              • 4. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
                dave_m_k Adobe Employee

                Hey Ken,


                Could you try the following steps:

                1. Run the CS5 Cleaner Tool and ask it to delete data related to the CS4 suite that was likely installed previously.
                2. Run the Acrobat Uninstaller.app (Mac).  (If you can’t find it immediately look for ‘Acrobat Uninstaller’ in Spotlight and that’ll find it for you.)
                3. Install Acrobat from media that came with CS5 and use the separate Acrobat 9 serial number that came with CS5.


                Please let us know the outcome!


                Kind regards,


                Adobe Systems

                • 5. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)

                  I have been having the SAME problem. I have CS4 on Lion and when Acrobat recently upgraded to Version 9.4.6 I can't open acrobat without the Suite Product Activation Needed. Nothing seems to help by opening my versions of AI or PS either.


                  David Friedman

                  • 6. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)

                    I am having the same problem here.  Adobe chat "support" said that the activation process is not suppported with Lion... They did not say the application was not supported, just the activation process. 


                    I originally installed Acrobat Pro as part of the CS5 Master Collection.  Since then I installed the Acrobat updates as they came out as well as the Mac OS X updates/upgrades as they came out.  My Acrobat Pro quit working after I upgraded my HD and did a migration assistant transfer of my time machine backups.  I know the original poster references cs4, but I get the exact same message. 


                    What sucks is that Adobe says I need to upgrade my entire suite just to get Acrobat Pro functioning (to X).  I thought paying $2600 for a software package would have at least entitled me a couple years of actual functioning software.  What sucks even worse is that I will probably do it because I have absolutely no other legal options.  Thanks Adobe.

                    • 7. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
                      Charles Barnes

                      And I am having the same problem here as well with the same message from Acrobat 9.5.1 as shown above: Suite Product Activation Needed.


                      I am running Mac OS 10.7.4 and I am a registered owner of CS 5.0.


                      Mac Pro (Early 2008)

                      Processor  2 x 2.8 GHz Quad-Core Intel Xeon

                      Memory  2 GB 800 MHz DDR2 FB-DIMM

                      Graphics  NVIDIA GeForce 8800 GT 512 MB

                      Software  Mac OS X Lion 10.7.4 (11E53)


                      Somewhat off-topic, but still related to the upgrade. My Photoshop CS5 perfomance was noticeably degraded after the 10.7.4 upgragde. It is now sluggish and I do get the beach ball during editing. The performance becomes even worse when the Firefox 13.0 browser is open.

                      • 8. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
                        Charles Barnes Level 1

                        I left the post directly above yesterday - 6/8/12 - so this is a bit of a follow-up in the hopes of helping the conversation.


                        On my Mac Pro - I could not open Acrobat 9.5.1. I clicked on a PDF, the file opened and then, very shortly afterwards, the "Suite Product Activation Needed" notice appeared. Although there was a 5 to 10 second window of opportunity see the document, the Reader frooze when the notice appeared and then the entire file disappeared when the notice was acknowledged after clicking the "OK" button.


                        When this issue first arose, I did re-open other CS 5 Applications like Photoshop and Bridge. That did not solve the problem.


                        Today - I re-installed Acrobat 9 Pro from the original CS 5 disk. The Acrobat 9 Pro folder containing 9.5.1 was replaced with the original 9.3.0. When I clicked on a PDF to open it, the same  "Suite Product Activation Needed" notice appeared. Again I reopened Photoshop and Bridge and, again, this did not solve the issue.


                        I am also now stuck on version 9.3.0. The downloaded upgrade to 9.5.1 does not recognize the older version when I click on the folder in which 9.3.0 is located.


                        I do have CS5 installed on my laptop:


                        MacBook 13-inch, Aluminum, Late 2008

                        Processor  2.4 GHz Intel Core 2 Duo

                        Memory  2 GB 1067 MHz DDR3

                        Graphics  NVIDIA GeForce 9400M 256 MB

                        Software  Mac OS X Lion 10.7.4 (11E53)


                        I use my laptop infrequently, but it is current in it's software updates for Mac OS 10.7.4, Firefox 13.0 and CS 5 but I am not experiencing the same problem with Acrobate Pro 9.5.1. My unscientific opinion is there the issue is isolated to my Mac Pro.

                        • 9. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)

                          I just encountered this problem today, after migrating my CS5 software to a new iMac.


                          Running Acrobat's uninstaller, and then reinstalling from the original disc, resolved the issue for me. I did not run the CS5 Cleaner Tool.


                          Edit: The version now installed is 9.3.0.

                          • 10. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)

                            OK, got a new solution; This problem plauged me for months and yesterday I finally stumbled on an answer, and it was NOT on Adobe's site - but what took months of Adobe chat techs keeping me busy for hours trying solutions that didn't work, this worked in seconds.


                            This is with CS5, Acrobat 9.3.0, which are both part of the CS5 Design Premium suite upgrade I purchased, and this is on OS X 10.8.2, Mid 2010 iMac with 3.2GHz Intel i3.


                            I got this solution from this website:



                            I made my own list to detail what I did; your mileage may vary:


                            First step is to make sure all products are installed, including Acrobat Pro.


                            The next step is to download the license repair tool from Adobe at


                            Next, locate the cache.db file from the Library/Application Support/Adobe/Adobe PCD/cache folder, and throw it in the trash.


                            Next, locate the Flex net Publisher folder in the /Library/Preferences folder and throw it in the trash.


                            Now, mount the dmg file downloaded from Adobe.


                            Go to Applications/Utilities and launch the Terminal application.


                            Enter the following:

                            cd /Volumes/LicenseRecovery\ 11.6.1/LicenseRecovery/

                            sudo python LicenseRecover.py


                            and hit Enter.


                            Enter password when prompted.


                            (There are instructions for multiple attempts, but this only took one try for me.)

                            At the ?, hit Enter.


                            This only took a few seconds and the process completed. Please note, the file warned of a processor error code but the file completed successfully anyway.


                            I then opened Acrobat Pro, and was presented with a registration dialog box to enter the serial number. I entered all information requested.


                            I then opened Photoshop, and was presented with the dialog box to enter the product serial number. In the course of this I also had to enter the serial from the upgraded product, which I just happened to have gotten out of storage "just in case".  I entered all information requested and Photoshop opened.


                            I then opened Dreamweaver, and was presented with a dialog box to enter my Adobe ID, or to create a new account. I entered my current account information and Dreamweaver opened.


                            I then opened all other CS5 Design Premium apps and all opened successfully. I have since then updated all apps to current updates.


                            I should also mention that I tried to update Acrobat over the web automatically but had a problem that required me to restart to clear the screen of the Safari plug-in dialog box. Investigating the website, it appears that each update to Acrobat Pro 9 required the previous update before it, so I went and downloaded all of them and installed them one by one. It all works now as it should.


                            Hope that helps somebody, this whole thing drove me crazy and had me looking for Adobe alternatives!

                            • 11. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)

                              Ran into the exact same issue in Win7 (on Dell Precision M6600, 64-bit) after needing to reinstall the Suite.  After reinstall, Adobe Acrobat Pro would not work without tossing out the error listed here.  Removed the entire Suite (CS4), reinstalled with defaults, ran all updates, and same error for Adobe Acrobat Pro. 


                              * I went into Photoshop & DEACTIVATED the suite (under Help menu)

                              * Restarted Photoshop, REACTIVATED with my license number, and haven't had the error show up again. 


                              UPDATE (2 days later):

                              It's back again!!  ;-P  So, obviously, that was only a temporary 'fix' and I still need help! 

                              • 12. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
                                Eric Bleak Level 1

                                I have found the answer, I think. This has worked for me so far (crossing fingers) after days of pulling my hair. This was after I upgraded my home machine to CS5, deactivating CS4 and installing CS5, trusting blindly in Adobe to properly do the upgrade.


                                Go to Start - Control Panel - Programs and see if you have CS4 installed. If so, UNINSTALL it. The only thing that will show up in the CS4 installer is Acrobat. Get it started and go make coffee or something. This will take a while. (Remember how slow CS4's installer was.)


                                Once the installer is finished cleaning out the last of Acrobat, get your CS5 disk set and install Acrobat from your CS5 disk set. Run PhotoShop and print something to PDF, opening the PDF as part of the print process.


                                Now close PhotoShop and open a different PDF. Presto! Up will come the registration and everything will work fine from there.


                                Hope this helps folks.

                                2 people found this helpful
                                • 13. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)
                                  ellka Level 1

                                  thank you WmChrisHoward! This worked on the first try for me.


                                  for others needing to do this — in mountain lion, the FlexNet Publisher folder was in Library/Application Support

                                  • 14. Re: “Suite Product Activation Needed” (Acrobat Pro 9.5.0)

                                    This 100% worked for me, on a Mac, @Eric Bleak. I just needed to uninstall CS4 with the Adobe uninstaller (which is in Utilities). Super easy, thank you.