14 Replies Latest reply on Mar 14, 2012 4:09 PM by Clint Porter

    Playback / JKL is so finicky! Why is that?

    Clint Porter Level 1

      Recent FCP convert here. Does anyone else have trouble with Premiere playback being really touchy? Sometimes it works just fine. Other times JKL will stop working, and nothing will happen when you press spacebar (except the "play" icon changes to a "stop" icon).



      If it does play, sometimes it will play fast, pitching everything up, or play slow, pitching everything down (this has nothing to do with the JKL shuttling speeds; it can happen just using the space bar.)



      Sometimes when I fiddle with seemingly random parts of the program or if I restart it, everything will start working fine again.



      Does anybody else have problems with this?



      It seems to happen regardless of the formats or codecs being used, and it doesn't matter whether my footage is on the internal drive or on my fibre RAID-5. (These files play fine in FCP) It also can happen with GPU acceleration on or off.



      My system: Mac 2.93 2x4core Xeon, 24MB 1066 RAM, NVIDIA Quatro 4000, Apple Xserve fibre RAID-5, working mostly with DV footage in a DV timeline.

        • 1. Re: Playback / JKL is so finicky! Why is that?
          Clint Porter Level 1

          Nothing? Well at least I'm glad others don't have this problem. Gives me hope that PP is more robust than my experiences with it so far have been.


          Right now all my talent sounds like Thomas Hayden Church when I hit space bar. The best fix I've found is to put Mac's focus on another app (like Chrome) and go back and forth between apps a few times. This often straightens the mess out (but sometimes it makes it worse!) It takes awhile to do this, too, because Premiere always sits there for a few seconds after getting focus before it starts responding to commands.

          • 2. Re: Playback / JKL is so finicky! Why is that?
            John T Smith Adobe Community Professional & MVP

            The easy way to insure that your video and your project match

            See 2nd post for picture of NEW ITEM process http://forums.adobe.com/thread/872666


            Does your video match your file, so there are no red lines before doing any work?


            • 3. Re: Playback / JKL is so finicky! Why is that?
              Jim_Simon Level 9



              Well...nothing I'm allowed to post.

              • 4. Re: Playback / JKL is so finicky! Why is that?
                Clint Porter Level 1

                My base video matches my sequence settings (Quicktime DV NTSC), so no red or yellow bars over the whole thing. I have some layers supers and Animation GFX in some places, but I don't need to be near those parts for the problem to pop up. And, when the problem goes away, those parts play fine too.

                • 5. Re: Playback / JKL is so finicky! Why is that?
                  Clint Porter Level 1

                  It happened to me again just now–Spacebar and JKL do nothing except toggle the play icon. I just tried getting rid of all layers except the base video, closed the sequence, and opened it back up. No red or yellow bar, just the DV footage. Still won't play.


                  I added all the other layers back in so I have yellow render bars again. Clicked on Adobe Media Encoder, and back on Premiere. Now spacebar plays, but at slow speed with pitched-down audio. Clicked on Media Encoder, and back on Premiere a few times. Now everything plays fine at proper speed with all layers.


                  At a loss…

                  • 6. Re: Playback / JKL is so finicky! Why is that?
                    Glitchdog Level 1

                    Hey Clint, another switcher here. I use JKL all the time. You definately should not be having this issue with DV footage and the system you have. I get it with AVCHD mostly on our offline iMac system because the codec is so complexed.


                    Can you open Activity Monitor and see if there are other things happening on your system?

                    Only one timeline/sequence open?

                    Have all internet ports closed while editing?

                    Just guesses.

                    • 7. Re: Playback / JKL is so finicky! Why is that?
                      Clint Porter Level 1

                      Thanks for the help. Things don't seem to be maxing out on Activity Monitor, and the frequency of this problem seems to stay the same whether I'm running a bunch of simultaneous AE renders or whether Premiere is the only thing running. It doesn't "feel" like a limited resources issue, but I could see it being some kind of software conflict where something is interfering with the proper operation of the playback engine. I had Premiere CS4 but I honestly never used it, so I don't know if it's Mercury-specific.


                      I'm curious what your line of thought is with the internet ports. I checked my built-in Mac firewall and it was off, so I turned it on and we'll see what happens.

                      • 8. Re: Playback / JKL is so finicky! Why is that?
                        Clint Porter Level 1

                        Firewall's on and my talent's talking like Darth Vader again. Hmmmm…

                        • 9. Re: Playback / JKL is so finicky! Why is that?
                          Jim Curtis Level 3

                          What your problem may be is that you're using Pr on a Mac.  There seem to be a lot of strange issues that Windows users don't have.  DV footage shouldn't be that much of an issue.  I have most of my playback issues with Long-GOP media.  Intraframe usually works pretty well, and DV is intraframe.  Have you tried trashing your prefs yet?  That's usually the first think I do when any app starts acting differently from how I'm used to seeing it.  I use a tool called Preferences Manager by Digital Rebellion to keep copies of "good" prefs for Adobe CS, Apple FCS, and Media Composer.  The whole suite is helpful for a variety of things.  I'm not an employee or paid endorser; I just have found the suite useful, since the prefs are easily corrupted for Pr CS5.5, Ae 10.5, and FCP7.


                          Also... corrupt media plays havoc with Pr.  Any single corrupt clip in an active sequence can prevent Pr from working correctly.  You can suss corrupt media with Digital Rebellion's Corrupt Clip Finder, or simply by removing clips a few at a time, or starting a new project with different footage, etc.


                          In general, I never know if I'm going to have a good or bad day with Pr.  Sometimes, I just use it to piece Ae ProRes renders together, and to create an audio track.  That's one of the simplest tasks I throw at it.  No effects or anything fancy.  And my audio will cut out, stutter, stop playing altogether, and other issues.  Other times, it works for hours on end, even with .mpg footage, without a single problem.  Some times, when I drag the CTI left and right over the timeline, I see thousands of frames go by; other times I may see 1 per second.  I haven't detected a pattern, yet.  And anything that's not reproducable or predictable, given a fixed set of circumstances, isn't something that Adobe can put any effort into trying to fix.  And this is partially why you see the smarmy remarks about getting a Windows computer on which to run Pr.


                          But, let me add... I still prefer Pr 5.5 to FCP7 and MC5 and 6.  I don't think I'd want clients in the room while I was working, but given the speed at which I can work with a Quadro 4000 installed, the gains offset some of the losses.

                          • 10. Re: Playback / JKL is so finicky! Why is that?
                            the_wine_snob Level 9

                            Can you educate me on "JKL?"


                            Google shows a lighting mfgr., construction companies, yam growers, Jimmie Kimmel Live, and a myriad of other definitions for that acronym, but I am hard pressed to figure out which ones might apply to Video editing with PrPro.


                            Thank you, and good luck,



                            • 11. Re: Playback / JKL is so finicky! Why is that?
                              Jim Curtis Level 3

                              J = reverse play

                              K = pause

                              L = forward play  (click twice to go 2x; 3 times for 3x)

                              • 12. Re: Playback / JKL is so finicky! Why is that?
                                the_wine_snob Level 9

                                Ah, the J-K-L buttons! Duh...


                                Thanks for that. It just did not register for my dull brain.





                                • 13. Re: Playback / JKL is so finicky! Why is that?
                                  Glitchdog Level 1

                                  I have a locations setting on our Mac "All ports off", that I use whenever I'm editing or doing anything that's very processor intensitive. So basically no ethernet or wifi. There's always stuff going out to see about updates, etc and I want all the resources possible.


                                  JKL I think was a former US president, but I don't discuss politics online


                                  Before we installed the Quadro 4000 I had lots of issues playing JKL smoothly with only one video layer, especially any comps in the timeline like AE. Though I have not tested any comps lately, all else seems to play very smoothly until I get a few layers in there, then I just have to render or go to 1/4 rez playback. (MacPro 5,1, 12 gigs mem, 4000 card, Firmtek eSATA RAID, 10.6.8) The system is actually very stable, no crashes in PP or OS thus far.

                                  We did have some serious issues with an audio filter, denoiser, kept crashing an offline iMac. So many potential barriers.


                                  Sounds like Jim has some excellent suggestions I need to write down for future ref.

                                  • 14. Re: Playback / JKL is so finicky! Why is that?
                                    Clint Porter Level 1

                                    I think I've found the solution to this problem!


                                    In Audio Hardware preferences, I've always used "System Default Input/Output". This is a handy setting which causes Premiere's audio output to "follow" whatever you've set to be the output in Apple's system preferences. I've always used the equivalent setting in FCP as well, which worked fine in that application.


                                    I tried switching this to any other setting, and all my problems have gone away. Currently I have set on Line Output, which is the system default anyway. It looks like Adobe mishandles something in its attempt to follow Apple's output. Don't know why. But I'm glad I found a workaround, even if it means I have to change the setting in Premiere prefs every time I want to pick up the headphones.