2 Replies Latest reply on Jul 14, 2012 9:52 PM by thedragonking

    DW CS5 - CSS can not save, "sharing violation"

    deborah_64554

      I'm having some trouble working with CSS in Dreamweaver CS5. Often when I'm cross-browser testing, DW won't let me save the CSS file after making a tweak due to a "sharing violation".

       

      I am NOT using coldfusion, and I do NOT have a site set up. In this case, I am using DW ONLY to construct the standalone CSS file.  The site is constructed in Eclipse.

       

      Closing down Firefox does not resolve the problem. Closing down DW does not usually resolve the problem. It seems all I can do is stop and restart my site in Eclipse.

       

      The CSS saves fine if I open it in Eclipse or Notepad, which suggests it is definitely DW. But neither of these programs enable fast CSS authoring as DW does, and both convert all of my tabs to spaces and make a huge mess in SVN.

       

      I read all of the threads on this issue from 2003 and 2006, but none of the solutions worked.

       

      Is there a workaround? This is phenomenally irritating!

        • 1. Re: DW CS5 - CSS can not save, "sharing violation"
          deborah_64554 Level 1

          After several hours of hunting around, it seems as if Firefox is caching the CSS, although it's strange that other apps can still edit it. 

           

          This solution seems to have resolved the problem, at least temporarily:

           

          In the Firefox browser address bar, enter "about:config"

           

          In the list of Firefox settings, double click on the following to set them to false:

           

          • browser.cache.disk.enable
          • broswer.cache.memory.enable
          • browser.cache.offline.enable
          • network.http.use-cache

           

          So far no more sharing violations in DW CSS... hope this helps someone!

          • 2. Re: DW CS5 - CSS can not save, "sharing violation"
            thedragonking

            I solved mine. I had 2 .index.php files in the same directory. I deleted the other file from that directory, and it solved it. Check to see if the directory that contains the file has another file of a similar name (I had index.php and index2.php, I deleted index2.php and the error went away) I hope this helps in someway.