4 Replies Latest reply on Feb 29, 2012 7:29 PM by Jeff Arola

    Image window maximize over title bar and tools

    sheep shooter

      Hi,

      im working on a PC , with windows 7, with photoshop CS5

      i searched everywhere for answer , but none was given..

      people did mention this problem, but for different photoshop versions , and, i had it good till i dont know what happened and changed it, so i believe it is fixable but people understood it wrong.

       

      anyhow, the problem is, when you try to maximize the image window (assuming you changed it from tabs), the window maximize all over the screen, over the tools and title bar.

      instead of staying inside the workspace.

      as i mentioned, it used to be like it , but something happened and now its all over the thing.

      i tried double click the hand tool, all sort of things with the "F" and Tab shortcuts, the arrange documents thing on the top, even trying to restore default setting but nothing really did the trick.

      i tried to look for something called "Application frame", that somehow suppose to do just that, under window->Application frame, but its not there.

      again, it used to be ok so i know there is still hope..

       

       

      here it is restored, under "fit screen" option, notice it only get the hight right, i would not call it "fit screen" but what ever..

      red circels show the title bar and tools.. very nice and cool.

      http://i.imgur.com/KWqDj.jpg

      and this is when i hit the maximize button and unleash hell, red circles are where the title bar and tools were, not so nice and cool..

      http://i.imgur.com/jrQu8.jpg

       

       

       

      i noticed none of the others gave pictures, so i gave it a go..

      please help, there are no words to describe how annoying it is.

       

      thank very much in advance.

        • 1. Re: Image window maximize over title bar and tools
          Noel Carboni Level 8

          If you want the Photoshop main window components to remain visible, either right-click on the image with the Zoom Tool selected and choose "Fit on Screen" (which really fits it inside the Photoshop workspace), or use Tabbed View.

           

          Pressing Control-0 (control zero) is a shortcut for Fit to Screen.

           

          I have no idea why Adobe changed the behavior.  Perhaps people reported that it was annoying to have the maximize window button not actually maximize the document window to fill the screen, which is really what it's supposed to do.

           

          -Noel

          • 2. Re: Image window maximize over title bar and tools
            sheep shooter Level 1

            the fit on screen gives me an image, restored, with the hight right but not the width, just as you see in the first picture (also with ctrl+0 , zoom tool right click, and double click the hand tool).. i did mention it.

             

            still, it was OK a couple of days ago, something i did, changing windows, tools, i dont know, cuased it, thats why i found it alright to post this question again, though no answer was given in the past.

            so if it was OK and got messed up, there must be a way to un-mess it..

             

            thank you anyhow, but it didnt worked.

            • 3. Re: Image window maximize over title bar and tools
              Noel Carboni Level 8

              I know of no way to have a Maximize operation result in a window that fits inside Photoshop's application workspace, except (as I mentioned) to open windows in Tabs rather than using Windowed view.  Then the concept doesn't really apply - the entire workspace is available for document editing.

               

              I suspect you are remembering the behavior of an older version of Photoshop, but hey, I'm interested to know if you find a way to do what you say with Photoshop CS5.

               

              -Noel

              • 4. Re: Image window maximize over title bar and tools
                Jeff Arola Adobe Community Professional

                The only thing i can think of is you had the tool options bar, toolbox and panels undocked and that"s why they were on top when you had the document window maximized.

                 

                 

                Untitled-2.jpg