3 Replies Latest reply on Mar 4, 2012 10:18 PM by Flex harUI

    bin-debug works but bin-release doesn't

    Omererer

      I have had this issue countless times with my Flex applications. When I export a release build of my application, it is not able to load my initial configuration files and thus my application can't start. Everything works fine if I run the application from bin-debug folder. For this reason, I often have to deploy my bin-debug folder's contents which are much larger in size.

       

      I am loading those configuration files through URLLoader. All paths being loaded at run-time are relative to the SWF's location. I have tried the compiler option -use-network=true but it didn't help. The release version doesn't throw any run-time errors. I uploaded bin-release folder to my server and saw the HTTP requests in Firebug but none of those requests is loading the SWZ files or my configuration files. However, when I monitor the requests made by my bin-debug application, it loads all the RSLs (SWF files in bin-debug's case) as well as my config files.