2 Replies Latest reply: Mar 5, 2012 5:01 AM by Steve Grisetti RSS

    Files seems to skip frames when importing into Premiere Elements 10

    mcffl807 Community Member

      I am importing .mts files from a sdhc card. When trying to import the .MTS Files into Adobe Premiere Elements 10 it skip frames at clip transitions. When i place the files onto the timeline it looks like a 'jump' between clips, as if frames were missing. The same happens when I import .vob files from a dvd. A long seqence gets interrupted by a quick drop in audo and a quick jumpcut. How do i fix this ?

        • 1. Re: Files seems to skip frames when importing into Premiere Elements 10
          Nash_John Community Member

          Make sure that your project preset match your source files specifications(fps, resolution, PAR, etc.).

          To know the specifications of your file, you can use the free utility MediaInfo and then make a PrE project with a matching preset.

          There shall be not red lines above your clips in timeline.

           

          Also after editing make sure that your render your timeline.

          • 2. Re: Files seems to skip frames when importing into Premiere Elements 10
            Steve Grisetti CommunityMVP

            As John says, matching your project settings to your video is vital to a successful editing experience. If you've got a match, you will NOT see red lines above your clips when you add them to your timeline. Is that the case in your project?

             

            Also, AVCHD video often requires at least a quad core or i7 processor with a good load of RAM to edit. If you don't have a powerful, well-tuned system, it could well be that the skipping you're seeing is just your computer unable to process the video data fast enought.

             

            How fast is your processor and how much RAM do you have? What OS are you running?