7 Replies Latest reply on May 24, 2013 9:35 AM by Cody Powell

    Transparent background instead of color for stage

    Kawboy2 Level 1

      Is there a way to set the background color for the stage to transparent instead of a color? I only see color as options when clicking in property manager for the background.

        • 1. Re: Transparent background instead of color for stage
          adninjastrator Level 4

          Do you mean transparent while designing in Flash or after you publish the .swf to use on a Web page?

          On the Web page you add the parameter wmode transparent to the embed code to give the stage a transparent background.

          <param name="wmode" value="transparent" />

          Best wishes,

          Adninjastrator

          • 2. Re: Transparent background instead of color for stage
            Kawboy2 Level 1

            Either one, but after I publish for sure. I found the wmode command in the publish window, but that didn't work. In the stage properties section, there is a background setting there. You can only select a color and not a transparent background. I had a "background" layer, which I deleted and tried that, but still the background color showed in playing the flash item. It seems that background setting for the stage is my problem, and I don't see how to change that to transparent. I'm sure I'm missing something but sure could use some help.

            • 3. Re: Transparent background instead of color for stage
              sinious Most Valuable Participant

              By default there is no background color with wmode="transparent" set. You may just be a victim of browser cache. Clear your cache as flash has a nasty habit of staying in there a while. What that does is tell the browser that you should be able to see through the flash piece in the browser.

               

              Mind you, flash doesn't always play nicely in all browsers. Sometimes you expect content to render 'over' flash (drop-down menu or such) and the browser still shows the flash item 'over' the menu. This is normal.

               

              If you're exporting a projector, you cannot export a projector with a transparent background. You will need an extension to flash projectors such as MDM Zinc or Screentime mProjector (Zinc is preferred). They can export transparent projectors (as well as a ton more).

               

              Any time you load a SWF inside another, the background will ALWAYS be transparent as well. The document background property has absolutely no effect on this. If you want a background you explicitly have to put a background layer in your SWF to have one.

              1 person found this helpful
              • 4. Re: Transparent background instead of color for stage
                adninjastrator Level 4

                Well remember that the wmode is for the HTML Web page and not the Flash stage. So just start with the default plain white stage... don't draw a white layer... just don't select any background color at all. If you do select a background color and the Flash is the only thing on the Web page during testing...  the entire Web page is given the same background color as the Flash... even areas of the page that the Flash are not on. So you might have a transparent background over a red page (for example) but it would all appear to be red... since what is underneath the Flash is a red page.

                So in the HTML, be sure to have something under the Flash so you can actually tell if you are getting the transparent background or not. Include something like this in the HTML Web page <head> to give the background of the page a gray color.

                <style type="text/css">

                <!--

                body {

                background-color: #cccccc;

                }

                -->

                </style>

                If you still have trouble, post a link to the actual page.

                Best wishes,

                Adninjastrator

                • 5. Re: Transparent background instead of color for stage
                  Kawboy2 Level 1

                  It appears that for some reason, the wmode was not being set to transparent. I set it to "transparent windowless" in the html settings in the publish section, but when I looked at the code on the page, it was not set to transparent. So, I manually changed the code to <param name="wmode" value="transparent" /> and that fixed the problem. I guess I didn't have something set right in the publish or some other section but don't know what. It took both your responses for me to realize this. Thank you both for your replies, got it fixed anyway!

                  • 6. Re: Transparent background instead of color for stage
                    adninjastrator Level 4

                    You are welcome! Glad you got it fixed!

                    Adninjastrator

                    • 7. Re: Transparent background instead of color for stage
                      Cody Powell Level 1

                      What about dropping in a .swf file that's got 2 interactive buttons with NO BACKGROUND for the stage.. Into a Powerpoint 2010 file. The background is Black, and I need it Transparent!..

                      THanks