6 Replies Latest reply on Mar 16, 2012 4:02 PM by cfg_2451

    multi-cam editing crashing gtx285m

    cfg_2451 Level 2

      I've been using the Production Premium CS5 suite for 18 months more or less. No problems other than the usual learning curves. But as time goes on we get more ambitous, yes? So now I want to try my hand at multi-camera editing. I'm only using two cameras. Got footage imported, and got both video feeds onto a "source" time line. Made a new "multi-cam edit" timeline to hold the multicamera stuff. Got the footage to sync (an adventure, but now I better understand the use of slates ).

       

      But while doing that PPro crashed my display. That is, sprinkled random pixels about, then everything froze up. After 30-60 seconds, Win7 popped up a notice that said the display had crashed and that it was restarting. But as you might have guessed, this didn't help PPro much -- the new instance of the display driver didn't know that PPro was up and running. So I had to kill PPro using the Task Manager. And even though the display was working (I could do normal functions like start a web browser, etc.) the display was now "sprinkled" with wrong pixels making it annoying. So I rebooted (cold boot). Everything came up fine and I started again. As soon as I started playing the source timeline, it crashed again. Filled the Program Monitor with hash, then locked up solid. Went throught the same reboot sequence and tried a third time. This time it let me get far enough that I was playing the source timeline. Same crash, but this time I had sound running -- PPro continued running the timeline (I could tell because the sound contined uninterrupted) while the display driver blew up and tried to recover.

       

      I can't make this kind of crash happen with any other program. I can't make it happen with PPro doing single camera editing. It seems to be a multi-camera deal.

       

      I did check to make sure that Win7 was up-to-date, and it is. So is the nVidia driver for the GTX 285M card in this laptop.

       

      The only thing I can find in the event logs is an entry for each event, a warning, from the display, event id 4101 with the text "Display driver nvlddmkm stopped responding and has successfully recovered."

       

      So... anyone have any ideas what the problem is? Any way to solve it?

       

      Oh, yes, this is an i7 930 processor at 2.8 GHz, with 6GB memory running Win7 64bit. The only program running when this happens is PPro, no browswer, no iTunes, no other Adobe software, just PPro CS5.

      --

      Bruce Watson

        • 1. Re: multi-cam editing crashing gtx285m
          Jim_Simon Level 8

          Which driver are you using?

          • 2. Re: multi-cam editing crashing gtx285m
            cfg_2451 Level 2

            Turns out, that's an interesting question.

             

            When I go through Win7 Device Manager, it says I'm running 8.17.11.9716, released on 3/16/2010. When I click on the "Update Driver..." button and make it search the 'net for the latest drivert, it comes back with "Windows has determined the driver software for your device is up to date." Which is why I said that my drivers were up to date in my original post.

             

            Yet, when I go to the NVIDIA website I learn that the current version is 295.73 - WHQL, and it was released just two weeks ago.

             

            So I'm thinking that win7 is lying to me, but the nomenclature for the driver is so different from the two sources that it's difficult to say what's actually going on. So... what do you make of this situation?

            --

            Bruce Watson

            • 3. Re: multi-cam editing crashing gtx285m
              John T Smith Adobe Community Professional & MVP

              >thinking that win7 is lying

               

              That is correct... always go to the hardware vendor site

              • 4. Re: multi-cam editing crashing gtx285m
                Jim_Simon Level 8

                I agree with John.  Windows doesn't always have the latest available driver.  All it's telling you is that you have the latest available from Microsoft.

                 

                So definitely update that directly from nVidia.

                • 5. Re: multi-cam editing crashing gtx285m
                  Harm Millaard Level 7

                  Bruce,

                   

                  8.17.11.9716 means driver version 197.16

                   

                  After updating to driver to 295.73 , Windows will show 8.17.12.9573

                  • 6. Re: multi-cam editing crashing gtx285m
                    cfg_2451 Level 2

                    Took a while, but I think I'm beginning to understand what the problem is. It seems to be a memory starvation issue.

                     

                    I upgraded to the latest and greatest from NVIDIA, but all that did was get rid of the glitter bomb effect. It also let the computer BSOD so that I could see that it was in fact the NVIDIA driver that was crashing, and the problem seemed to be that the NVIDIA driver was accessing memory beyond its reach as it were. So the crashes were caused by the driver overwriting some other process' RAM. Not good. Worse, it doesn't let you know that it has encountered a problem -- nothing in any of the error logs I could find. So it left me not knowing what to fix, or even where to look.

                     

                    Basically, it looks as if someone working for NVIDIA has been lax with their return codes and error handling in their resource management. Been there, done that, been royally reamed for it, fixed it, tested it until I could scream. Every frellin' product. But that's what it takes to make a good product. Which is why I'm so surprised that NVIDIA's code does this (sound of gnashing of teeth).

                     

                    So... first test is to upgrade the laptop from 6GB to 12GB (4GB SODIMM has dropped probably 5x in price since I bought the laptop a couple of years ago, or at least it feels like it ). It's probably too early to tell yet, but so far PPro has become stable again. The multi-camera monitor comes up and behaves normally. Unfortunately I've got to so some filming tomorrow so I probably won't get back to editing until Sunday. But I didn't want to let thread go to long without updating it in case anyone else is having a similar problem.

                     

                    Message was edited by: cfg_2451 to make it a little more clear