10 Replies Latest reply on May 31, 2013 9:58 AM by ECBowen

    I Updated BIOS and my RAIDs went offline

    alexdejesus Level 1

      After I updated to the new 2023 BIOS for my ASUS P8P67 Pro mobo, the computer rebooted in AHCI mode. I rebooted and set it back to 'RAID' but could not recover the RAID volumes. I had most everything backed up, so not a huge problem, but would sure like to recover the configuration. Strange thing is the Windows disk manager lists the RAIDs twice. N and O are two 2-disk volumes - Disk 1 and 4. They are listed again as 2 and 3 'Not initialized' and 'Unallocated' Is it possible to recover them? Diskp Mgr.jpg

        • 1. Re: I Updated BIOS and my RAIDs went offline
          Alan Craven Level 4

          I don't know whether you can get your RAIDs back, but I do know how to avoid the losing of them happening.

           

          Usually when you update the BIOS, you either have to load optimised BIOS defaults (eg. with Gigabyte boards), or these are loaded automatically, before the first re-boot after the BIOS update (sounds as though the latter happened to you).

           

          What you MUST do at this re-boot is enter the BIOS before Windows starts to load and re-enter the settings that you need - in this case alter the SATA port settings to RAID.  You also need to enter any other BIOS settings that were not at default.

           

          It pays to keep either a written record of your non-default BIOS settings, or take screen shots of the relevant screens before you start.

           

          One odd thing I notice from your screen shot is that your pair of drives are not identical capacity - this is not a good idea.

           

          You could try disconnecting the drives, then re-boot.  Enter the BIOS and check that the SATA ports are set to RAID and let Windows boot.  Check that both sets of entries for the drives are gone.  Now shut down, and re-connect your drives exactly as they were before.  Now re-boot and see if your RAID array has re-appeared.

           

          If one of the experts appears, they may have some better advice.

           

          Good luck.

          1 person found this helpful
          • 2. Re: I Updated BIOS and my RAIDs went offline
            alexdejesus Level 1

            IRST.jpgThe two RAIDs are listed here, but one drive from each is listed separately. I tried disconnecting and reconnecting all the drives. Didn't work. I'll wait a bit more for advice, then I'll have to re-initialize. There must be some way to fix this, though

            • 3. Re: I Updated BIOS and my RAIDs went offline
              Harm Millaard Level 7

              All my raid settings are done in BIOS, never with the Intel software. I would go into the BIOS settings and try to revive your raid arrays there.

              1 person found this helpful
              • 4. Re: I Updated BIOS and my RAIDs went offline
                JEShort01 Level 4

                I have not used either of the following utilities, but thought they could help for your rather nasty sounding situation:

                 

                http://www.overclock.net/t/478557/howto-recover-intel-raid-non-member-disk-error/20

                1 person found this helpful
                • 5. Re: I Updated BIOS and my RAIDs went offline
                  alexdejesus Level 1

                  TestDisk didn't work. Made a post at overclock.net forum, where that link was

                  • 6. Re: I Updated BIOS and my RAIDs went offline
                    ECBowen Most Valuable Participant

                    Sometimes the onboard raid controllers get confused when the controller mode switches and you boot past the controller initialization. They essentially recognize the Raid Volume data/XML data on the primary drives of the array but not the secondary drives. That is why the Intel Management utility still shows the array but the secondary drives as unconfigured. Disk management just does not recognize the disk type so lists those 2 drives as you see them because the Disk record has been adjusted by the raid data. Normally there is no way to recover the raid from this or atleast that I have found with the onboard raid controller. Raid Controller cards with a good firmware/driver/management give you the option to import foreign configurations to try and resolve this. However this is not an option with the onboard controllers. Essentially you have to delete the raid volumes and redo them. One thing they may prevent this in the future should it happen again is if you change the disk type in Disk management from MBR Disk to GPT. GPT stores the partition table at the beginning and end of the drive so that should store the table essentially on both drives. Does not mean the controller will recognize this but it may.

                     

                    Also using the Rapid Storage Manager is essentially the same as using the bios utility. It just has a different GUI interface. So setting the raid up in the bios utility would nnot have changed this or any other function.

                     

                    Eric

                    ADK

                    1 person found this helpful
                    • 7. Re: I Updated BIOS and my RAIDs went offline
                      alexdejesus Level 1

                      So I ended up deleting the arrays and creating new ones. GPT.  I had to set up RAIDs in BIOS IRST as well as Windows Disk manager. All seems to be working. I lost a couple of things, but no show stoppers. We'll see if the new BIOS 2303 has any issues. If stable, I will attempt an overclock - but that's another discussion

                      • 8. Re: I Updated BIOS and my RAIDs went offline
                        Alan Craven Level 4

                        Harm,

                         

                        The Intel RST User Guide states that any RAID arrays set up after Windows has been installed should be done using the RST software in Windows.  Obviously this could be done only if  the SATA controllers had been set at RAID in BIOS before installing Windows.

                         

                        Someone, somewhere, needs to make clear the ramifications of the three possible settings for the SATA controllers in BIOS, and the need to be careful when upgrading either BIOS or SSD firmware - you have to have the drive on port 0-3, with the SATA ports set at EIDE, or possibly AHCI, to avoid losing your RAID arrays.  In both cases it is essential to re-enter the BIOS and set the ports back to RAID BEFORE allowing Windows to start loading.

                         

                        There is also the problem caused by changing to either of the two higher levels when Windows has been installed with the ports set at EIDE, which leads to a non-booting system.  Microsoft have a document (KB922976) which sets out a way round this, but it has to be done before the change is made.  It appears that their method cannot recover the system after the event

                         

                        Perhaps this is another job for you?

                         

                         

                        Percoplus,

                         

                        I am disappointed that my method of recovering your arrays did not work for you.  It worked for me when I made the same mistake.

                        • 9. Re: I Updated BIOS and my RAIDs went offline
                          alexdejesus Level 1

                          I downloaded EaseUS Data Recovery Wizard: http://www.easeus.com/datarecovery/  and was able to recover most of my lost files. I first had to re-create the RAIDs in BIOS with the same volume names, etc. Was GPT originally and I kept them that way. I then did a 'Complete Recovery' with the EaseUS software. It took a long while, and it scattered the files in all the wrong places - but at least they were there.

                          • 10. Re: I Updated BIOS and my RAIDs went offline
                            ECBowen Most Valuable Participant

                            That software is excellent. I also found out after my post that you can recover the partition with Paragon as well after you remake the raids. Easier and cleaner than Easeus.

                             

                            Eric

                            ADK