1 Reply Latest reply on Mar 10, 2012 4:03 PM by $Loki

    <visible> tag error returned when debugging?

    $Loki

      Hi!

       

      I'm having this annoying problem that I can't even get Google to return a single result related to. I've set in a Flex 4.6 project running in Flash Builder my application descriptor manifest's initialWindow <visible> tag to false. Unless something has changed in AIR 3.1 or Flex 4.6 to make that tag defunct (has it?) I'm not sure why I'm getting this when debugging or running the project:

       

      Process terminated unexpectedly.

      invalid application descriptor: Illegal value "<visible xmlns="http://ns.adobe.com/air/application/3.1">false</visible>
      <visible xmlns="http://ns.adobe.com/air/application/3.1">false</visible>" for application/initialWindow/visible.

       

      Launch command details:

      "C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\bin\adl.exe" -runtime "C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\runtimes\air\win" "C:\Users\[User Account]\Adobe Flash Builder 4.6\exampleApplication\bin-debug\exampleApplication-app.xml" "C:\Users\[User Account]\Adobe Flash Builder 4.6\exampleApplication\bin-debug"

       

      Can anybody give me some insight into why this might be happening? It happens no matter what I set the <visible> tag to, even if I leave the space between empty. Only when the tags are deleted or commented out will an application under Flex 4.6 and AIR 3.1 debug safely. It happens no matter what the project is; I've tried restarting the computer and reinstalling Flash Builder. I've tried using Flex 3.6A and AIR 1.5 as well - the tag seems to work fine in under that framework. It's just under Flex 4.6 and AIR 3.1 that I have a problem.

       

      Thanks for reading.

        • 1. Re: <visible> tag error returned when debugging?
          $Loki Level 1

          Doh! I knew it had to be something simple and stupid I was missing. The problem seems to be that there was already a set of active <visible> tags at the bottom of my descriptor that I hadn't seen, as well as the commented out ones near the top - so my descriptor had two instances of the same tag. Removed one set, and it works fine. Problem solved.