2 Replies Latest reply: Mar 24, 2012 1:23 PM by marilyn1978 RSS

    I'm trying to use Avery temples and it keep telling me to down load adobe 10.3 or better.

    marilyn1978 Community Member

      I bought the adobe app and It still won't allow me to use Avery templet.com