1 Reply Latest reply on Apr 10, 2008 5:43 PM by Newsgroup_User

    Sprite ignoring all scripts except beginSprite...

    Level 7
      This is a weird one. I've got a sprite - one of 10 identical sprites, which
      is not executing its code at all. The other 9 all work perfectly fine, and
      they all have the exact same behavior on them. This one guy executes his
      beginSprite code, and that's it. The mouse-events, exitFrame, and custom
      handlers on the thing don't even respond. (I tried using "put" commands in
      each of the other behaviors to see if it's even reading the code, but it
      isn't.) It has all its properties from the behavior (set in the
      beginSprite - the only one that runs on this one for some reason), and they
      can be altered via run-time scripts and checked via Message Window/Object
      Inspector. I'm not doing anything nutty like messing with
      scriptInstanceLists or puppetSprites or anything. (And if I were, I'd
      imagine that even if I'd somehow killed its scriptInstanceList, its
      properties given by that script would not be accessable anymore, and that's
      not the case.) As far as I can see, this sprite is being treated exactly
      like its 9 brothers, but for some reason, their code works and his doesn't.
      I've tried removing and reapplying the behavior, even deleting the sprite
      and copy/pasting one of the others into it's location, moving it to another
      sprite channel, etc. Nothing seems to make a difference.

      I realize this isn't much to go on, but I couldn't begin to explain all the
      scripts going on on this thing, and I doubt any of you would have the
      patience to go through that much code anyhow. (It's a somewhat long script,
      though not unusually complicated.) I'm just wondering if anyone else has
      had something like this happen where a sprite just suddenly stopped
      responding to all scripts for no discernable reason...