27 Replies Latest reply on Mar 22, 2012 12:28 PM by Peter Spier

    I cannot edit my master pages

    TheNewbie1956 Level 1

      The master pages are visible but somehow I cannot edit them. I tried double clicking on the name and the page in all modes (select, page text etc) to no avail.

      I am now lost. I have tried different documents but that did not change anything.

      I am rather new at this software please give me some pointers (steps to take) to be able to i,e, create or edit a master page, I tried to move a page to the master to create one (in case I did not have one)

      Thanks

        • 1. Re: I cannot edit my master pages
          Peter Spier Most Valuable Participant (Moderator)

          Perhaps the layer is locked?

          1 person found this helpful
          • 2. Re: I cannot edit my master pages
            TheNewbie1956 Level 1

            Additional info. This doc is a MS Word import. What I have done is copied the master creating a new master and THAT is editable(!??), but the original, the result of the import is not. Why? who knows... a bug maybe?

            • 3. Re: I cannot edit my master pages
              JomThreethousand

              How exactly did you import the Word file?

               

              If you'd make a text frame on the regular page in which you place (file > place) the Word, you edit the master page by double clicking on the A-master in the Pages menu.

               

              http://creativecurio.com/wp-content/uploads/2008/06/indesign-master-page.jpg

               

              Did you do it like this or differently?

              1 person found this helpful
              • 4. Re: I cannot edit my master pages
                sssuuusssaaannn Level 1

                Sorry I don't have ID on the computer I'm working on now, but I did have

                the same problem as you and the solution is to open the page options menu,

                then click on an option that really doesn't look like it would have

                anything at all to do with editing...sorry I can't remember what it was,

                but if you wan to try, you could open up a copy of a master page and that

                menu and click away until you get to something that works, i.e., that after

                you click the option it'll be possible to move/delete a text box etc.  (I

                think it had something to do with ignoring exceptions...you can see I

                haven't done any work in ID in a while.)  Good luck!

                 

                Susan

                • 5. Re: I cannot edit my master pages
                  [Jongware] Most Valuable Participant

                  It may be a fair try to describe what you are doing, but I *think* you are in need of a Beginner's Course, just so you can use the proper terms to tell us the problem.

                   

                  >Additional info. This doc is a MS Word import.

                   

                  InDesign docs "are" no MS Word import. They may contain text -- and a variety of other objects -- imported from a variety of other files. Presumably you created a new document and imported some text into it.

                   

                  > What I have done is copied the master creating a new master and THAT is editable(!??),

                   

                  You copied the master page? Do you remember how? There are several ways to get something that *looks* like a straight on copy but are in fact something else.

                   

                  >.. but the original, the result of the import is not.

                   

                  Master pages are not a result of importing text.

                   

                  >Why? who knows... a bug maybe?

                   

                  That's of course always possible, but in this case I suspect PICNIC.

                   

                  Possibly, you are mixing up *regular* and *master* pages. If you put anything on a master page, you will see this appear on every *regular* page that has this master applied. However, this text is "not" editable as usual. You can even create a new master page *based on* the previous one, and you also "cannot" edit the text on THIS one either. But in both cases, you can "still" edit the original page. (I'm using quotes freely to indicate that's a Newbie's look to things, as all of it IS possible, of course.)

                   

                  I strongly suspect you imported and then placed your text on a real master page, and now you are looking at a regular page with unexplicably un-editable text.

                  • 6. Re: I cannot edit my master pages
                    TheNewbie1956 Level 1

                    when you "import" (well I used the Place) a MS word doc as a

                     

                    screen.jpg

                    as the result you DO get the pages original and master pages. You can create a master page and copy all the intristics into it, that is what I have done. BUT....

                     

                    Oh yes, I almost forgot the additional master pages are NOW gone, either I forgot to save it or the gremlins ate it

                    • 7. Re: I cannot edit my master pages
                      JomThreethousand Level 1

                      Not sure if that means your problem is solved now? The Page window shows a single page without style [None], the master spread(two pages) A-master and then under this double line, the document pages are starting. The A showing on these pages, means that they are based on the A-master, so they will show all elements that you've put on there. These elements are locked when you are on the document pages.

                       

                      Try this channel to see a nice startup tutorial http://tv.adobe.com/product/indesign/

                      • 8. Re: I cannot edit my master pages
                        Peter Spier Most Valuable Participant (Moderator)

                        In your screen capture your master pages have no content, so there is nothing there to edit. This is normal. You Select the master pages you widh to edit, add content, and that content then appears on any document page based on that master.

                        • 9. Re: I cannot edit my master pages
                          TheNewbie1956 Level 1

                          I understand, but when I try to drag a page to the master - it does not work. Maybe I am not understanding how to "load" a master page but I thought the blank masterpage can be clicked on and I can set up textbox for page numbers etc. Right now I cannot seem to figure it out...

                          PS

                          I have checked it is not locked....

                          • 10. Re: I cannot edit my master pages
                            JomThreethousand Level 1

                            The letter(prefix) you see on the document pages in the Page window, refer to the master it's based on. In a default document, you will see the letter A on all document page icons, referring to A-master. When making a new master, it will get a new prefix, like B,C, etc...  In the Pages Windows you can click on a document icon and choose 'Apply Master to Pages..' to change the master for the specific page.

                            • 11. Re: I cannot edit my master pages
                              Peter Spier Most Valuable Participant (Moderator)

                              TheNewbie1956 wrote:

                               

                              I understand, but when I try to drag a page to the master - it does not work. Maybe I am not understanding how to "load" a master page but I thought the blank masterpage can be clicked on and I can set up textbox for page numbers etc. Right now I cannot seem to figure it out...

                              You do seem to have a misunderstanding of how to add content to a master page.  You cannot drag selected items from your page to any page in the pages panel. You can drag them to an new document page in the layout window, however, so you could use Window > Arrange > New Window to open a second window for the smae file, then open a master page in that window and drage objects to it. If you want to save an entire document page (or spread) as a Master Page, you can drag the page icon in the Pages panel into the Master Page section and a coy will be created as a new master page, or you can select the page (or spread) and use the context menu to save it as a new master. None of those actions will remove the document page, nor will they assign your new master to any pages.

                               

                              Placing a word file can bring in things like styles and swatches, but it does not create any page structure. Your page sizes are determined by the Page Setup when you create the file. All new documents contain both a [None] master and an A-Master page with the size and margins you initially set, and one blank page based on your A-Master. The A-Master can also have an optional master text frame if you check the box during setup, and that frame will fill the margin guides. Any additional master content must be created by you.

                              • 12. Re: I cannot edit my master pages
                                [Jongware] Most Valuable Participant

                                Are you by any chance attempting to change the [None] master page? Now that's an uneditable one.

                                • 13. Re: I cannot edit my master pages
                                  TheNewbie1956 Level 1

                                  "

                                  Sorry I don't have ID on the computer I'm working on now, but I did have

                                  the same problem as you and the solution is to open the page options menu,

                                  then click on an option that really doesn't look like it would have

                                  anything at all to do with editing...sorry I can't remember what it was,

                                  but if you wan to try, you could open up a copy of a master page and that

                                  menu and click away until you get to something that works, i.e., that after

                                  you click the option it'll be possible to move/delete a text box etc.  (I

                                  think it had something to do with ignoring exceptions...you can see I

                                  haven't done any work in ID in a while.)  Good luck!

                                  Susan"

                                   

                                   

                                  No. I have a different document where the masters show that contain something and I cannot edit those either. It would be helpful if someone could tell me the steps to take one by one.  I am looking at manuals.(InDesign for Dummies

                                  • 14. Re: I cannot edit my master pages
                                    Peter Spier Most Valuable Participant (Moderator)

                                    Let's be clear about WHERE you want to edit this master content. To edit it on the master page itself, so the change progagates to all documetn pages based on the master, double-clcik the name of the master to open it, then you should be able to edit everything there that is not locked or coming from some other master page on which this one is based.

                                     

                                    To edit a master object on a document page, or on a master page that is based on another master, you need to override that object and release it from the master page. The easy way to do that is to Cmd (Ctrl on Windows) + Shift click on the object. Any parameters you then change will disconnect from the master and changes made on the master later will not be reflected in the overridden object.

                                    • 15. Re: I cannot edit my master pages
                                      TheNewbie1956 Level 1

                                      what "mode" do you have to be in to edit the master page? Text? Page? I have tried both, cannot double click on the name of the master, well I can but nothing happens. It is not locked...

                                      • 16. Re: I cannot edit my master pages
                                        JomThreethousand Level 1

                                        I think it's best you check out some basic tutorials at http://tv.adobe.com/product/indesign/ or http://www.lynda.com as it is hard for us to know to what extent you understand the first principles of Indesign.

                                        • 17. Re: I cannot edit my master pages
                                          Peter Spier Most Valuable Participant (Moderator)

                                          TheNewbie1956 wrote:

                                           

                                          what "mode" do you have to be in to edit the master page? Text? Page? I have tried both, cannot double click on the name of the master, well I can but nothing happens. It is not locked...

                                          When you double-clcik the master, what page is highlighted in the Pages Panel? Do you see objects on the page?

                                          • 18. Re: I cannot edit my master pages
                                            TheNewbie1956 Level 1

                                            screen2.jpg

                                            The master panel seems uneditable. I cannot click on the name of the master nor the icon of the master - well I can but nothing happens. On the pipcture posted there is nothing in the master-A but even when it was I could not edit it. Also in one document the leafs say they use master-B (page numbers) and I do not even show master B on the panel!!

                                            I went to update my InDesign version because this seems to be out of control. (well for usability and east this SUCKS) - the update did nothing....

                                            I know most people take courses etc but still, this is a simple issue. or at least it should be.

                                            • 19. Re: I cannot edit my master pages
                                              JomThreethousand Level 1

                                              Pull that double line in your Page Panel beneath the word A-Master down... the B-Master will most likely show up there, as you can see the scroll bar on the right of it.

                                              • 20. Re: I cannot edit my master pages
                                                Peter Spier Most Valuable Participant (Moderator)

                                                And in your screen capture you are working on the Document page #1, not a master page. Did you DOUBLE-click the name of the master?

                                                • 21. Re: I cannot edit my master pages
                                                  TheNewbie1956 Level 1

                                                  I have made a revelation of sort. I must use the goto page to edit the master, or show the extra master that is not visible via the panel. This is either a result of MacOS versus Widows or some goofy setting that one must do before embarking on any work. My guess is the latter.....I cannot believe that core fuctionality would differ from OS to OS...The other stickler is that even in the goto page list the Masters do not show up, I must type the name in. Any attempt to use the master panel, the scroll or double click on name yielded NO RESULT....

                                                  • 22. Re: I cannot edit my master pages
                                                    JomThreethousand Level 1

                                                    It's quite difficult to get a good idea of what's happening in your case. Maybe it's good to start of with a blank document and some dummy text to be sure you understand the functionality of the master page and the file is not somehow affected by the import of the Word file.

                                                    • 23. Re: I cannot edit my master pages
                                                      [Jongware] Most Valuable Participant

                                                      TheNewbie1956 wrote:

                                                       

                                                      I have made a revelation of sort. I must use the goto page to edit the master, or show the extra master that is not visible via the panel. This is either a result of MacOS versus Widows or some goofy setting that one must do before embarking on any work. My guess is the latter.....I cannot believe that core fuctionality would differ from OS to OS...The other stickler is that even in the goto page list the Masters do not show up, I must type the name in. Any attempt to use the master panel, the scroll or double click on name yielded NO RESULT....

                                                       

                                                      I see in your screen capture you are using Windows 7. Do you have a custom text size setting? (Don't ask me how to check, as I never changed it myself & therefore never had the problems that other people report.)

                                                      • 24. Re: I cannot edit my master pages
                                                        TheNewbie1956 Level 1

                                                        Yes, I use Win 7. I will look into the settings...I am still reading InDesign for Dummies....

                                                        Also, I have used a bunch of different docs, word and original Indesign alike. I am fully aware of the basic functionality of the panels etc, except when something does not work a way it is documented....

                                                        When I use goto page the master panel becomes fuctional and scrolling but still inside I cannot switch masters by clicking on ANYTHING only the goto page works! Weird.....

                                                        • 25. Re: I cannot edit my master pages
                                                          [Jongware] Most Valuable Participant

                                                          That's exactly why I asked about the screen text size. Changing this to something else than "default" in Windows 7 is reported to cause problems in InDesign's interface.

                                                          • 26. Re: I cannot edit my master pages
                                                            TheNewbie1956 Level 1

                                                            "That's exactly why I asked about the screen text size. Changing this to something else than "default" in Windows 7 is reported to cause problems in InDesign's interface."

                                                            Bingo....so is it this going to be fixed?

                                                            • 27. Re: I cannot edit my master pages
                                                              Peter Spier Most Valuable Participant (Moderator)

                                                              Your probelm doesn't sound like the font issue, but read this anyway: InDesign tools and panels don't respond to mouse clicks (Windows 7/Vista)