2 Replies Latest reply on Mar 19, 2012 11:05 AM by Peter Grainge

    Robohelp 8 - Reimported CPD, now all links broken & I can't restore them!

    trainingwriter555 Level 1

      Background: I had that shaky/switchy issue when I opened my Robohelp one day, so I renamed the CPD as old and reopened the project to generate a new CPD file. I've done this before without problems, but this time -- every single link shows up as a broken link. There is absolutely nothing in my Project Files. Grudgingly, I tried to just right-click on every single file and click Restore -- but it won't let me do that.

       

      When I go to Tools > Resolve Broken Links, it shows me this msysterious "a/p check files" topic under References to Selected Topic. I don't even have any topic named this. Regardless, it shows as with a key icon (I'm assuming meaning locked) and won't let me click Restore. If I try to restore any of the individual files on the lefthand side, it gives me the error message below saying these topics are outside the project folder.

       

      Any ideas what could be going wrong? I saved these files in the same place I always do, so they should be in the project folder. I can't think of anything I would have changed, besides getting rid of the old CPD file. I've been googling this issue and not finding anything.

       

      Also: I have tried installing updates (I have the 8.02 update, for example), re-importing the CPD file numerous times, tried to open from different file types (the HHP file is hopelessly old, so I can't use that or I'd lose the last several weeks of work. At least right now, I can see all my topics in the list -- albeit as broken links I can't restore)

       

      robohelp error.png