1 Reply Latest reply on May 3, 2012 7:38 AM by smurfsky101

    SharePoint NTLM web service from LC process problem

    Alhuntsman

      Hello all,

       

      I'm struggling to get a LiveCycle process to update an internal SharePoint list via its NTLM Windows authenticated web service. 

      Adobe LiveCycle Workbench ES2_2012-03-21_10-55-26.png

       

      As you can see from the above, the schema definition is loaded no problem, and I can select the operation I want to run.  I've used the "Test" tab to attempt to send a request to update the list:

       

      Adobe LiveCycle Workbench ES2_2012-03-21_11-03-24.png

      Attempting to test the web service call (in Workbench) gives errors in the UI along with the server.log all to do with authentication problems.  It's worth mentioning at this point that the "User name" and "Password" boxes on the Settings have been left blank in the screenshot.  I have tried all possible combinations here, and the error messages in the log differ for each scenario, demonstrated below:

       

      Error in UI for all:

       

      WebService Settings_2012-03-21_11-11-00.png

      Various Server.log errors:

       

      Blank Username / Password

       

      tmdevlcsrv01 - Remote Desktop Connection_2012-03-21_11-14-59.png

       

      Which made me think, "I'll add a test AD username / password" and see what happens..

       

      With Username / Password

       

      tmdevlcsrv01 - Remote Desktop Connection_2012-03-21_12-13-56.png

       

      Of course, "I'll add the domain before the username" and try again...

       

      With Username / Password (DOMAIN\Username & Password) - (tried both fully qualified domain & shortened)

       

      tmdevlcsrv01 - Remote Desktop Connection_2012-03-21_12-20-53.png

      But.. It's still asking for the DOMAIN?

       

       

      The solution for now:

       

      In the meantime, I've resorted to enabling BASIC authentication on the SharePoint site, which accepts the request and returns a response, but realistically we don't want to enable this for a production environment.  It also doesn't help explain what the underlying issue is with LC, or even if it's a LC issue at all!

       

      I eagerly await some experienced person to help with knowledge on the subject..

       

      Thanks,

       

      Alex

        • 1. Re: SharePoint NTLM web service from LC process problem
          smurfsky101 Level 1

          Our issue may be unrelated, but you will probably encounter issues with some of SP's native web services.

           

          I am also trying to set up processes in LC that insert list items into sharepoint, however some of SP's services in lists.asmx dont seem to have a properly exposed wsdl. I am able to get list items to properly insert (see below), and our server is set up with basic auth right now (behind the firewall).

           

          Once you get the right creds. over basic, do you have any issues publishing content (specifically using updatelistitems)?

           

          "

          <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:soap="http://schemas.microsoft.com/sharepoint/soap/">

             <soapenv:Header/>

             <soapenv:Body>

                <soap:UpdateListItems>

                   <!--Optional:-->

                   <soap:listName>Announcements</soap:listName>

                   <!--Optional:-->

                   <soap:updates>

          <Batch OnError="Continue" RootFolder="/Lists/Announcements">

          <Method ID='1' Cmd='New'>

          <Field Name='Title'>testforfields233</Field>

          <Field Name='Body'>!!!!!!!!!!!</Field>

          <Field Name='ApprovalStatus'>denied</Field>

          <Field Name='URL'>http://www.google.com</Field>

          </Method>

          </Batch>

                   </soap:updates>

                </soap:UpdateListItems>

             </soapenv:Body>

          </soapenv:Envelope>

          "

           

           

           

          Photobucket
          Photobucket