9 Replies Latest reply on Mar 23, 2012 2:43 PM by Dave LaRonde

    Memory Leak

    DHM711

      After reporting numerous system freezes while using AE CS5/Mac/10.6.8 I opened the Console and noted that the system is buys pumping out messages that read the following while it is hung up:

      *** __NSAutoreleasePool(): Object Oxxxxxxxxx of class NSCustom (or other classes) autoreleased with no pool in place - just leaking

       

      There are many dozens of these that appear in the Console Message log that I find after restarting. Some type of memory leak no doubt.

      AE is the ONLY app of many that I am having trouble with (FCP, CInema 4D, Premiere, Studio Artist, PS...) and it can happen while rendering, or while playing back a preview. No matter.

      This is now a huge problem and I am forced to restart my system at least four or five times a day.

      Any help woul dbe apprecisted.

      DM

        • 1. Re: Memory Leak
          Dave LaRonde Level 6

          Sorry, but without additional information, the best advice some people could give would go something like this:

           

          "AE doesn't like you anymore.  You did something to make it angry.  You should bring home flowers, take it out to dinner at a fancy restaurant and apologize.  Never mind that you don't know why you're apologizing, just apologize."

           

          Here's a good list of information to provide.

          • 2. Re: Memory Leak
            Mylenium Most Valuable Participant

            What Dave said. We need more info, and pretty detailed one at that. This must not at all be AE's fault, but could be a flakey Quicktime component or some driver you are using for some specialized equipemnt. If it wer that common, other users would long have reported it, so it must be something specific to your setup...

             

            Mylenium

            • 3. Re: Memory Leak
              DHM711 Level 1

              Here some additional info:

              • What version of After Effects? 10.0.2
              • Have you installed the recent updates?: current version is installed
              • What operating system? Ms OS/X 10.6.8
              • What kind(s) of source footage? Source footage is compyter genrated animation at 1920 x 1080 or 900 x 600 - same problems
              • If you are getting error message(s), what is the full text of the error message(s)? I am not getting any error messages from AE - the system simply freezes and I see many dozens of the following message in the console:
              • *** __NSAutoreleasePool(): Object Oxxxxxxxxx of class NSCustom (or other classes) autoreleased with no pool in place - just leaking
              • What were you doing when the problem occurred? I might have been rendering, or attempting playback...
              • Has this ever worked before? AE 5.0 worked much better before I upgraded to 10.6.8. I had been suing 10.5.8 and things are much worse after the upgrade
              • What other software are you running? None
              • Do you have any third-party effects or codecs installed? No
              • Tell us about your computer hardware. Include CPU type and number of processor cores, amount of RAM installed, GPU, number of disk drives, and how any external drives are connected.
              • Mac Pro 2008 - 16 GB RAM 2 x four-core procs Nvidiia 8800 GT card
              • Do you have any third-party I/O hardware (e.g., AJA, Matrox, Blackmagic, MOTU)? no
              • Are you using OpenGL features in After Effects?  no
              • Does the problem only happen with your final output, RAM preview, or both? both
              • 4. Re: Memory Leak
                DHM711 Level 1

                Thanks much,.

                I accept the premise that it is my system but have no clue how to trouble shoot. Additional info provided - hope that helps.

                Best.

                D.

                • 5. Re: Memory Leak
                  Dave LaRonde Level 6

                  When you changed operating systems, how did you do it: did you simply run the upgrade, or did you do a clean install? 

                   

                  FCP 6 & 7 in particular benefit from doing a clean install.

                  • 6. Re: Memory Leak
                    DHM711 Level 1

                    Bummer. I did an upgrade form a physical disc. Way too many apps to consider rebuilding the system at this point.

                    But hard to imagine that that explains what appears to be a memory leak - what would cause that?

                    And btw, no other app has given me any problems whatsoever after the upgrade (video, animation, music, etc).

                    Best.

                    DM

                    • 7. Re: Memory Leak
                      Dave LaRonde Level 6

                      Yours may be a situation where if you push FCP a little harder, it too may start to manifest odd behavior.  

                       

                      I'm thinking about things like cutting in H.264 (which is never a good idea), media management, stacking effects on clips, speed changes, nesting and multicam editing, to name a few.  These sorts of things really bother FCP if you do a simple upgrade rather than a clean install.

                       

                      All I can tell you is that guys who cut shows for delivery to networks on FCP swear by the process of the clean install, running updates over and over until no more of them appear, and then cloning the system drive to be put away in a secure location.  Just in case.

                      • 8. Re: Memory Leak
                        DHM711 Level 1

                        Thanks Dave. I am not doing anything at all complex. Generating 900x 600 or 1920 x 1080 uncompressed animations in my anim software then loading them into AE on a single layer and keyframing their position (working on a large public screen project). No effects, no plugs, nothing at all 3rd part. Not even close to "pushing" the system.

                        Simply trying to sort out the memory leaks that are occurring repeatedly in AE and no other software, assuming that's what the console is reporting (haven;t had any confirm of that yet).

                        Best,

                        Dennis

                        • 9. Re: Memory Leak
                          Dave LaRonde Level 6

                          No, you're not pushing your system. 

                           

                          However, both FCP and AE are probably the two most revised, appended, patched, and quirky pieces of software on your machine, each with a long legacy of a core programming algorithms that haven't really changed much in a long time.  They may not be tolerant of an OS that isn't 100% solid.  That's why I mentioned pushing FCP.

                           

                          That's part of the reason why FCP editors do clean installs, and it could explain why AE is freaking on you.  I can't say for sure, because I have IT people who deal with my machines. 

                           

                          All I can say is that you started having problems after the OS upgrade, you run FCP, you didn't do a clean install, but power FCP users insist on a clean install to avoid OS-related problems.