5 Replies Latest reply on Mar 26, 2012 7:39 AM by Jim Curtis

    Scratch Disk is write protected or unavailable

    rbtjonas

      I see earlier discussions on this, but the tentative solutions don't work for me.  Quick overview of my problem:

       

      I'm on an 8-core MacPro, running Premier Pro on the latest Lion, 10.7.3. I'm connected to a MaxxDigital RAID5 tower via an R380 ATTO card.  My scratch disks have been on the RAID5 tower.  About a week ago I used some CoreMelt plug-ins on PP and experienced a crash.  Then another and another.  Couldn't fix it and finally had to do a complete Erase and Install.  Call it horrible or call it Spring Cleaning to the Max. (Be careful of CoreMelt!). 

      I'm finally up and running but every time I open a PP project I get this message, "scratch disk write protected or unavailable." I've checked to see that the RAID5 is set on "Read and Write" in every category, and I don't use dashes, underlines or slashes in my titles.  I see no settings in PP Preferences to fix this.  What's going on?  I'm in the middle of a project.  Help!  (Robert at rbtjonas@aol.com)

        • 1. Re: Scratch Disk is write protected or unavailable
          rbtjonas Level 1

          p.s. If I go into Disk Utility and click on the Maxx Digital RAID5 drive, I see that the "s.m.a.r.t. status is not supported."   When I click on two other internal HD's, I see that their s.m.a.r.t. status is supported.  Could this be my problem?  Thanks so much!

          • 2. Re: Scratch Disk is write protected or unavailable
            Jim Curtis Level 3

            SMART reporting is either built into the drive, or it isn't.  I use Seagate SAS drives now.  They're not supported.  My previous SATA drives were.  No big deal.

             

            I suggest you do a Finder Get Info on your RAID icons, set the permissions to everyone read and write, and/or Ignore Ownership on this Volume.

            • 3. Re: Scratch Disk is write protected or unavailable
              rbtjonas Level 1

              Hi Jim,  Thanks for thinking about how to do this.   The thing is, I know that this MaxxDigital RAID 5 system works with my MacPro and with Premier, because it was working fine before I had to do my Erase and Install.  I don't know whether the SMART thing was "not supported" when everything was working fine.

               

              I have done a Finder Get Info and set everything on the RAID 5 to "read and write" and saved that setting, but that didn't change anything.  I still get the "scratch disk is write protected or unavailable" if I try to set my scratch disk to the RAID 5.   

               

              Any other ideas out there?

               

              Robert

              • 4. Re: Scratch Disk is write protected or unavailable
                Stephen_Spider Level 3

                I've seen 5 or 6 mac users with permission issues since last August. Windows, can't remember anyone on the forum with that problem.

                • 5. Re: Scratch Disk is write protected or unavailable
                  Jim Curtis Level 3

                  There's a freeware app called BatChmod that you can use to get agressive with permissions settings, but personally, it scares me a bit.  I wouldn't mind using on my RAID, as all I have on it is media and projects, and don't need to have any privacy settings (I'm a one-man shop.).  But, I wouldn't use it on my boot disk, as I don't understand the implications of some of the settings.

                   

                  You can go to your drive maker's site, look at the spex for your model, and find out if SMART is supported.  IIRC, all SMART does is report certain hardware problems.  I don't think it has anything to do with permissions.

                   

                  You're certain your RAID is selected as Scratch Disk, right?

                   

                  If so, have you tried deleting your preferences?  (Hold option while launching.)