2 Replies Latest reply on May 16, 2012 1:25 PM by AFincher

    Flex4.6 - Failed to Install

    AFincher Level 1

      Hey everyone,

       

      I've been developing in Flex/AS3 in FlashBuilder for a while now and this is my second project using the setup. I recently tried to install my progress onto one of my iOS devices but got the iTunes Failed to Install error.

       

      After loads of investigations and actually performing the 4.5-4.6 upgrade as regenerating my certificates and provisioning files I still have no luck.

       

      When I attempt to install via the iPhone Configuration Utility, I get the error 'kAMDMissingBundleIdentifierError' come up.

       

      My application very much does have an application identifier.

       

      The only thing that I can think of that may have any bearing on this is that I'm using two Libraries (Box2D and my own custom library). Is there something extra special that I should have done when including my own? For reference, it was created in the same workspace and that was by selecting new Flex Library (non mobile as I planned to use it on the web as well) and then dragging the appropriate classes into the new Libraries src folder (within FlashBuilder).

       

      So any thoughts, corrections or guidance?

       

      Thanks heaps.

       

      Aaron

       

      Edit:

      For reference, I'm creating another mobile project and I'm very gradually adding the functionality that my other one has in it. It now has the libraries and isn't having a cry so I'm guessing that's not it after all...

       

      Update:

      I created the app from scratch, gradually adding components and function calls until it broke. I got quite a bit of functionality in,but what it actually stopped working on was adding my resources folder in, so a folder called Resources in the src root, containing some sub folders and 3 images and 1 xml file.

       

      Now the part that makes it all the more frustrating is that I've since removed the resources folder and it's still not working...

       

      Anyone have any ideas?