1 Reply Latest reply: May 22, 2012 5:55 AM by Apurva Udaykumar RSS

    FMS 4.5 Live streaming issues

    cafardtom Community Member

      Hello everyone,

       

      I've installed FMS4.5 on a CentOS server with Appache and both servers works fine.

       

      I'm trying to set it up for live streaming and I've followed the simple step by step instructions provided by Adobe.

       

      I can push my stream on to the server as a multiple bitrates 100-200 and 350 k everything works fine.

      I can see teh 3 streams being created in /opt/adobe/fms/applications/livepkgr/events/_definst_/liveevent

       

      but when I tried to access the http://myserver.com/hds-live/livepkgr/_definst_/liveevent/livestream.f4m

       

      I get an empty manifest:

       

      <manifest xmlns="http://ns.adobe.com/f4m/1.0">

       

      <id>livepkgr/events/_definst_/liveevent</id>

       

      <streamType>live</streamType>

      <duration>0</duration>

      </manifest>

       

      My Event.xml looks good:

      <Event>

        <EventID>liveevent</EventID>

        <Recording>

          <FragmentDuration>4000</FragmentDuration>

          <SegmentDuration>400000</SegmentDuration>

          <DiskManagementDuration>3</DiskManagementDuration>

        </Recording>

      </Event>

       

       

      And here is my Manifest.xml

       

      <manifest xmlns="http://ns.adobe.com/f4m/1.0">

        <media streamId="livestream1" bitrate="100" />

        <media streamId="livestream2" bitrate="200" />

        <media streamId="livestream3" bitrate="350" />

      </manifest>


       

      Any help is very very welcome