5 Replies Latest reply on May 18, 2012 9:09 AM by RLS

    The internal html viewer is not working in coldfusion builder 2.

    Eguaoje

      It is so frustrating how hard this is. I finished setting up coldfusion and coldfusion builder 2 with an apache local webserver and was hoping to make use of the internal html viewer but it won't come on! All I see is a blank grey page with no content. After creeping around the forums for a while it seemed that the simplest solution was to use the internal coldfusion server so I uninstalled everything and did just that, reverting my administrator page to http://localhost:8500/CFIDE/administrator/index.cfm (working and launchable from the IDE), placing my webroot at C:\ColdFusion9\wwwroot and with all the folders in their right place. The server is running ok and when I launch the run as "coldfusion administrator" option to run my index file, it succesfully opens the external browser and displays the page.

       

      I have the same setup on my desktop at home, the same files, installation, everything! and it works but not on my laptop. I followed Ben Forta's instructions to a T and yet I still am not getting the html preview. I even tried to hard code the absolute url in the html preview settings and still nothing but that annoying grey.

       

      Is this a bug? There doesn't seem to be anything about it in the bug reports. It is quite infuriating how something that seems so miniscule could be such an annoyance. I have already gotten quite used to the preview pages and coldfusion and I would prefer to code that way rather than making use of dreamweaver which I feel I am being forced to use, but at least it's consistent.

       

      Please if anyone could provide some answers and help I would really appreciate it! I have only so much hair left!

      Thanks!

        • 1. Re: The internal html viewer is not working in coldfusion builder 2.
          charlie@carehart.org Adobe Community Professional & MVP

          Perhaps others may recognize and resolve this for you. I and others here often can and do offer quick solutions to many problems. And I can appreciate that it’s reasonable to think that something so simple should just work. But in this case I think are simply too many variables that could explain why things are not working for you. And while I can also appreciate that you will prefer to get a solution for free if anyone can offer it, I just can’t even begin to offer all the possible problems and solutions, at least by email, in this case. Again, maybe someone else will make a quick connection.

           

          But I will point out that if you’re willing to pay US$75, I offer a service of remotely troubleshooting any one CFBuilder problem for that fixed price. Hopefully I might help you solve it quickly (when I can see exactly what’s going on in your environment), but you will not pay if I don’t solve the problem in up to 2 hours effort. If you may be interested, see www.carehart.org/consulting/ for more, and if you want to set up a time to get together (over the web), drop me an email at charlie@carehart.org.

           

          Finally, please note that I don’t often point out this service here on the forums. I generally just offer suggestions (sometimes lengthy ones) without any commercial expectation, so please don’t regard this as me engaging in “abusive unsolicited commercial email”. I’m just offering a possible solution, given the OPs sincere challenge in solving things.

           

           

           

          /charlie

          • 2. Re: The internal html viewer is not working in coldfusion builder 2.
            seattlebears

            Before you lose too much hair, be sure to check out the HTML Preview settings. They are located under Properties for your project. If your project has a URL that works in a browser, put that URL in the "Use absolute URL" section, and check off "override workspace settings." This would be something like http://testmyproject. If you don't do this Coldfusion Builder will use default settings.

             

            Craig

            • 3. Re: The internal html viewer is not working in coldfusion builder 2.
              Eguaoje Level 1

              Thanks so much for replying me although I had pretty much resigned myself to dreamweaver since I'd already run out of hair ^_^.. I had done everything you suggested before but just for safe measure I tried it again to no avail (If you recall in my original post I mentioned that I set the absolute url and without checking off the override workspace settings there would be no way to do so in the html preview settings)..I still am not getting any html previews. I don't want to cough it up to borked software but I am kind of amazed that there has been such little resolution of this in the forums and no official word on this being a bug, which I am beginning to suspect is the case since apparently none of the similar issues have gotten a conclusive fix ergo: http://forums.adobe.com/message/2516886#2516886 and http://forums.adobe.com/thread/936545

              • 4. Re: The internal html viewer is not working in coldfusion builder 2.
                RLS Level 1

                Did you ever get a solution to this problem?  I have five servers defined, but still get the No Server Defined when I try to run something, and none of these servers show up in the dropdown in HTML Preview when asked to define a server. Very frustrating!

                • 5. Re: The internal html viewer is not working in coldfusion builder 2.
                  RLS Level 1

                  We were able to resolve this issue for us. Make sure you use the absolute url, check the Append box, and put the full url in the box that also works  in an external browser. It will look something like this: http://127.0.0.1:8500/BobProject/Bobswebsites/ such that you're pointing to the root of your project. 

                   

                  One big clue is that you need to have installed your CFB workspace (and, thus,project) UNDER your ColdFusion?\wwwroot directory (in standalone; under the InetPub\wwwroot directory on a server - or whatever your server directory to your websites where CF executes them).

                   

                  Good luck!