1 Reply Latest reply on Apr 14, 2008 7:05 PM by www.jamesward.com

    user agent for firefox/linux causes false errors

    stevecrozz1
      I'm not going to do any extra debugging, but I thought I'd mention an issue that might drive some traffic away from this web application. When I load kuler.adobe.com in my browser I get "kuler requires the latest version of the Adobe Flash Player. " even though I have the latest version I could find (9.0.124.0). When I change my user agent string to a more common one (IE7 w/ Vista), I get: "Express install is not supported by this version...". But if I just bypass all the pointless string checking and crappy error handling I can use the application perfectly by simply pointing directly at the final destination swf which today is: http://kuler.adobe.com/kuler_20080318.swf

      This should really be fixed. The first (and correct) user agent string was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Ubuntu/7.10 (gutsy) Firefox/2.0.0.13, then I tried: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1).