4 Replies Latest reply on Apr 3, 2012 5:52 AM by functionoverfashion

    PE 10 - won't start up - says display.dll is fault module

    functionoverfashion

      My system is a Dell Vostro 3750 laptop

      4 gig ram

      Intel i5 2.4ghz

      500gb Hard Drive

      64-bit Windows 7 SP1

      Graphics: Intel HD Graphics Family / NVIDIA GeForce GT525M

      I have a second screen plugged into the VGA port, it's an Acer 22" LCD.

       

      When I open PE 10 it brings me to the splash screen and when I click on 'new project' it crashes, with the error below:

       

      Problem signature:

        Problem Event Name:    APPCRASH

        Application Name:    Adobe Premiere Elements.exe

        Application Version:    10.0.0.0

        Application Timestamp:    4e791009

        Fault Module Name:    Display.dll

        Fault Module Version:    6.0.0.0

        Fault Module Timestamp:    4e78fee0

        Exception Code:    c0000005

        Exception Offset:    00000000000230bc

        OS Version:    6.1.7601.2.1.0.256.48

        Locale ID:    1033

        Additional Information 1:    ceb1

        Additional Information 2:    ceb18ffac49ee9446e74d894cfb4b4db

        Additional Information 3:    a6f0

        Additional Information 4:    a6f009316aeeeb289b1c7014c1d50d50

       

      I have the latest QuickTime installed, and everything (windows) should be up to date. I updated the NVIDIA driver to one dated 2/29/12 (the latest on their website).

       

      Any thoughts or suggestions are welcomed!