4 Replies Latest reply: Apr 19, 2012 10:28 AM by Rallymax-forum RSS

    H264 output bitrate don't match

    TaoHunter Community Member

      I'm having a problem rendering a couple of H264 videos.

       

      They all have the exact same length and screensize.

      I'm importing them into AME as After Effects compositions (1080p25)

       

      I'm rendering them with a 18Mbps CBR setting so they should all be the same size eventually if I'm not mistaking.

      The problem is that they are not and when I open them in Quicktime and check their bitrates they show up ranging from 10 to 15 Mbps, so not even the setting I gave them.

       

       

      Anyone any idea?

        • 1. Re: H264 output bitrate don't match
          JSS1138 Community Member

          What are the sizes?

          • 2. Re: H264 output bitrate don't match
            Rallymax-forum Community Member

            If the image can be compressed to a point where the image is visually lossless in less than 18mbps then it didn't need to make compremizes and drop information to fit into the 18mbps maximum you set. Why add zero padding if you don't need it (ie bumping the 10mbps to 18)?

             

            As Jim asks, what are the export sizes? - 480p is a lot smaller than 1080p and thus takes 4 times less to describe.

             

            Also, what is the material? If it's mostly static images then you definitely don't need 18mpbs to describe it. For example, last week I rendered out a screen capture of a presentation at 1080p and was able to do it lossless at 1mbps since almost nothing changed except the mouse moving and windows popping up occasionally. In that case I set the max to 4mbps but afterwards (in MediaInfo) saw that it only needed about 1mbps.

            • 3. Re: H264 output bitrate don't match
              duocycle Community Member

              I'm also having this same issue. I understand that it makes sense for Media Encoder to use the lowest possible bit rate to make it visually lossless but I'm wondering if there's a way to just force it to an exact bit rate regardless of what Media Encoder thinks would be best for me.

              • 4. Re: H264 output bitrate don't match
                Rallymax-forum Community Member

                I change me stance..

                I've been doing some 12.5 CBR and VBR encodes and they come out between 6.4 and 6.5 and are NOT lossless (you can stack them up in a squence using "difference" instead of "normal" and see the artifacts. Note that the estimated size is right - ie based on 12.5mpbs/second.

                 

                So I think there is something wrong with encoder.