9 Replies Latest reply: Mar 15, 2013 6:38 AM by MarkRomine RSS

    Can't start Photoshop - 'Could not open a scratch file'

    Selrek Community Member

      Hi, I recently installed Photoshop CS5, however every time I open the application, I am receiving this error message at the loading screen:

       

      "Could not open a scratch file because the file is locked or you do not have the necessary access privileges. Use the ‘Get Info’ command in the Finder to unlock the file or change permissions on the file or enclosing folders."

       

      I've looked online for solutions everywhere, but I've obviously been unsuccessful and I'm at the point where I have no idea what else to try, other than a clean install of my OS, however that is a last resort as I currently do not have an external hard drive to transfer my files to do so. So far I have tried these things:

       

      • Reinstalled Photoshop many times, even the CS6 BETA is giving me the same error.
      • Deleted preference files within /Library/Preferences/
      • Used the cmd+alt shortcut when starting Photoshop to select a different scratch disk location.
      • Used the cmd+alt+shift shortcut to delete the settings file, which I cannot do as the error message mentioned above appears before the window for deleting the settings file does.
      • Tried rebooting several times, even into safemode and I still get the same message.
      • Tried changing the permissions on the Applications folder, Adobe folder, CS5 folder and CS5 application, however they are all set to 'read & write access' for me. I am also set as an administrator.
      • Cleaned my cache of any unneccessary files.
      • I have also repaired my permissions using Disk Utility, but that didn't solve the problem.

       

      I have a 2010 Macbook Pro, 4GB RAM running OS X Lion 10.7.3 with 2 patitions on my harddrive (OS X and Windows 7). I have 15GB free on my OS X partition currently, which may not seem like much, however I have run Photoshop CS5 previously as a trial and other versions of Photoshop and the small amount of harddrive space has never affected the software's ability to create a scratch file.

       

      The strange thing, however, is that I can use Photoshop CS5 & CS6 on a guest account that I created recently, which means that the problem I am having is permissions based. Logging into a seperate account is a good enough solution for now, but it is incredibly tedious to keep changing accounts just to use Photoshop.

       

      Has anyone got any other ideas? As I mentioned previously, reinstalling is a last resort as I currently don't have the neccessary resources.

       

      Thanks.

        • 1. Re: Can't start Photoshop - 'Could not open a scratch file'
          station_one Community Member

          Here's something to try:

           

          While in the Finder and BEFORE launching Photoshop, highlight the icon of the hard drive where the scratch disk resides, do a Get Info (Command I) and see if you can check the box that says "ignore ownership of this volume" or some such verbiage.

          • 2. Re: Can't start Photoshop - 'Could not open a scratch file'
            Selrek Community Member

            I'm not seeing that option in the 'Get Info' screen, however after some Googling it seems like this could work. Is there any way that I can get this option to appear?

             

            EDIT: After a bit more reading, it turns out that the option will not appear if you are currently booted into said harddrive. I'm unsure about how to get around this.

            • 3. Re: Can't start Photoshop - 'Could not open a scratch file'
              station_one Community Member

              Sorry, I overlooked the fact that you are on a MacBook laptop and are using your boot drive as your scratch disk drive.  My bad. 

               

              Then, I have no further ideas.  15 GB is way too little space for Photoshop's scratch disk drive, especially when that very small space is being shared with the swap files of the OS.  I wouldn't be surprised if the reason only an administrator can run it on your machine is actually a protective measure.

              • 4. Re: Can't start Photoshop - 'Could not open a scratch file'
                Selrek Community Member

                Hm, I'll create and boot into a small partition and try to check the option that way. If that doesn't work, I guess I'll have to do a clean install.

                 

                I've used Photoshop when I had even less space than 15GB so I'm unsure about that, but I may clear some stuff out and see if that works anyway.

                 

                Thanks!

                • 5. Re: Can't start Photoshop - 'Could not open a scratch file'
                  station_one Community Member

                  It's painfully obvious that I'm not qualified to give advice in a situation like yours.  Sorry.

                   

                  Generally speaking, one should NOT partition the only drive in a laptop, as the space available to the swap files of the OS and to the Photoshop scratch disk does not need to be limited a priori by the constraints of partitions.

                   

                  Of course, I'm deliberately ignoring your apparent need for a Windows partition, because i wouldn't remotely know how to handle that.

                  • 6. Re: Can't start Photoshop - 'Could not open a scratch file'
                    Selrek Community Member

                    I managed to fix this myself, almost by accident, after failing every method suggested that I came across.

                     

                    My problem was due to 'read only' access being set to some folders in ~/private/ on my main account, meaning that Photoshop could not create an important, temporary scratch file in this location.

                     

                    To anyone else who comes across this thread due to having the same problem, here's the solution:

                    1. Open finder, then go to 'Go' in the menu bar and select 'Go to folder'
                    2. In the window that opens, enter '/private/' and click 'Go'
                    3. Then, right click on the folder 'tmp' within /private/ and select 'Get info'
                    4. In here, scroll to the permissions section and change the relevent user permissions to 'read and write'
                    5. Before closing this window, click on the gear icon underneath the list of users and select 'Apply to enclosed items' and hit 'Ok' in the next window.
                    6. Finally, repeat steps 3 - 5 for the folder named 'var', also within /private/ and you're done. Photoshop should now open as intended!

                     

                    Although this solution was ideal for my home laptop, giving 'read and write' access to important folders like these can probably lead to lowered security so please do it at your own risk.

                    • 7. Re: Can't start Photoshop - 'Could not open a scratch file'
                      MarkRomine Community Member

                      When I do the '/private/' command the OS tells me that the folder can not be found.

                      • 8. Re: Can't start Photoshop - 'Could not open a scratch file'
                        PrintFusion45 Employee Hosts

                        The /private folder is a hidden folder. However, if you navigate to Go > Go to Folder and within the Go to Folder window enter just "/private/" without the quotes, then it should take you to the private folder. Make sure you're typing it exactly as it is here. Folder/file names are case sensitive.

                        • 9. Re: Can't start Photoshop - 'Could not open a scratch file'
                          MarkRomine Community Member

                          Well I tried all of these steps finding the /private/ folder and changing the permissions to 'Read and Write' and the OS is still not saving the changes to the 'ignore ownership' button.