14 Replies Latest reply on Dec 27, 2012 3:37 AM by praveen : techie

    Vaultclipse plugin

    rojazz

      Has anyone got vaultclipse plugin working for Eclipse in windows machine.  I have it working just fine in Mac.

      In windows, same configuration gives me filenotfound error when "import".  It looks like it exports in different folder and tries to import from different folder.

       

      Any thoughts?

        • 1. Re: Vaultclipse plugin
          meetshishir

          I was able to get vaultclipse plugin working for eclipse indigo . The only changed i made was changing the default  "temporary directory" setting from user home to my d:\temp .

           

          you can try this and let me know. I tried import and export and both seems to be working fine. I did not try the merge option yet.

           

          1 person found this helpful
          • 2. Re: Vaultclipse plugin
            rojazz Level 1

            Thank you for the response!

             

            I have tried that and it stopped the null error but I am still cant import. I still get

             

            Here are my settings:

             

            OS: Win XP

            JAVA_HOME : C:\Program Files\Java\jdk1.6.0_25

            VLT_HOME: C:\adobe\cq5\author\crx-quickstart\opt\filevault\vault-cli-2.4.18

            PATH:C:\Program Files\Java\jdk1.6.0_25\bin

            Eclipse indigo:

            Plug in http://vaultclipse.sourceforge.net/update

            Plug in setting : Vault Directory: C:\adobe\cq5\author\crx-quickstart\opt\filevault\vault-cli-2.4.18

            Temprorary directory : C:\Temp ---> this folder exists

             

            Can you share your settings? Any installation would be greatly appriciated.

            • 3. Re: Vaultclipse plugin
              rojazz Level 1

              The error message i get is:

               

              import: java.io.FileNotFoundException:

              C:\eclispe_indigo\temp\vaultclipse\1333744653895

              • 4. Re: Vaultclipse plugin
                meetshishir Level 1

                Hey,

                 

                i also got the similar error once i change my Temprorary directory : from D:\temp to C:\Temp. 

                 

                but reverting to "D"   or any other drive are working fine for me.

                 

                My guess it could be because of some windows security reason. Try moving your  Temprorary directory from c: drive to any other drive . It works for me hopefully it works for you.

                 

                yours other setting are same as mine except OS , i am using windows 7 professional.

                • 5. Re: Vaultclipse plugin
                  meetshishir Level 1

                  Are you able to configure the plugin?

                  1 person found this helpful
                  • 6. Re: Vaultclipse plugin
                    RoyAsking

                    Check that you have available the filevault command. Eg. vault-cli-2.3.6

                     

                    Try making a Fresh installation of the plugin.

                     

                    It works fine on Windows too.

                    1 person found this helpful
                    • 7. Re: Vaultclipse plugin
                      rojazz Level 1

                      It didnt work for me. I installed new eclipse but still no luck.  I will let you know when I get it to work.

                       

                      Thanks for the help.

                      • 8. Re: Vaultclipse plugin
                        klcodanr85 Level 1

                        rojazz,

                         

                        I noticed that the error you're getting seems to indicate that your temporary directory is set to: C:\eclispe_indigo\temp\  Why not leave it the default setting?  I think this may be the root of the problem you are having.  I would try setting it to another directory and see if that fixes your issue.

                        1 person found this helpful
                        • 9. Re: Vaultclipse plugin
                          cqlearner Level 1

                          I have left it to default path too but it wont work.

                          • 10. Re: Vaultclipse plugin
                            RameshBacha

                            we too got the same problem with vault-cli-2.4.18 which is shipped with CQ5.5. But when we used the vault-cli-2.3.6 which is shipped with CQ5.4 it's working fine.

                             

                            create a new workspace for eclipse and configure your vault plugin to point to vault-cli-2.3.6. It worked for us.

                            • 11. Re: Vaultclipse plugin
                              cqlearner Level 1

                              That was it !!! Thanks a bunch Ramesh.

                              • 12. Re: Vaultclipse plugin
                                rojazz Level 1

                                Thanks Ramesh !!

                                • 13. Re: Vaultclipse plugin
                                  klcodanr85 Level 1

                                  The new version of VLT shipped with CQ 5.5 fixed an issue with the way VLT handled paths in windows.  Since VaultClipse did some path munging to build paths compatible with the previous version of VLT on windows, the fix broke VaultClipse.  I updated VaultClipse to only do the path munging on the older versions of VLT, the newest release of the plugin, 0.3.1 fixes this issue and makes some other minor updates.

                                   

                                  This new version is committed to the update site, so if you run the Eclipse plugin update you should be able to pull it down.

                                   

                                  Sorry this fix took so long, I was off the first half of this month.

                                  • 14. Re: Vaultclipse plugin
                                    praveen : techie

                                    Hi ,

                                     

                                    I am working on vaultclipse plugin with cq 5.4, it is working fine for me, but there is small issue that is, I want to Export a specific folder from /etc to my eclipse repo., but there is no link between the filter.xml and the vault plugin, can we define it in filter.xml , what to export and import....

                                     

                                     

                                    thanks in advance....