7 Replies Latest reply on Jun 30, 2015 10:49 AM by firthybloke

    Missing/Hidden fonts after creating a package




      Our graphics department connects to a Lion server with Font Explorer so all the fonts are centrally located. When creating a package in indesign they can see the selected fonts but after the package has been created the fonts that are on the server are missing/hidden in the package and the fonts that remain are ones that are installed locally on the iMac's. Any idea what would be causing this?

        • 1. Re: Missing/Hidden fonts after creating a package
          sdumire Level 1

          Here's a little bit more detailed explination on what's going on....



          Any time I package a file for print, only a few fonts carry through. The fonts that carry through are located in either my sytem or user fonts. However, the fonts that never make it through the packaging process are located on the Shared folder where the FontExplorer fonts are stored.

          When I choose to locate these font in Finder, they show up under a folder Users > Shared > .FontExplorer X Server that is greyed-out/hidden. This is in a folder that is actually above mine (brandon.harrison) in the hierarchy.

          When I try to move the packaged folder into a new folder, Finder requests admin username/pass to make changes. Upon further digging, I can actually move all the files contained within this packaged folder except, guess what, the “Document Fonts” folder. Coincidence?


          Theory tested:

          I tested my theory by hopping into Terminal and revealing all the hidden files. Sure enough, the .FontExplorer X Server folder is hidden (which I already knew because of the period “.” preceding the folder name). To test my theory even further, I went back into the packaged folders that had all the problems in the first place and guess what I saw? The supposedly “missing” fonts were actually in the folder but they were hidden. This makes perfect sense why InDesign said all the fonts were packaged properly. The files were located in the packaged folder but, because their parent folder had hidden permissions, they too inherited those same properties.



          Unlock the Users > Shared > .FontExplorer X Server folder and remove it’s hidden property.

          Move the .FontExplorer X Server folder to a different location that we have access to? There’s a way to move the directory from within FontExplorer’s preferences but I’m hesitant to do so. If we don’t have permission to move the files in Finder, I fear the process would get hosed within FontExplorer as well. I’d rather this be a last resort cuz I’m flying blind here.

          Other suggestions?

          • 2. Re: Missing/Hidden fonts after creating a package
            Peter Spier Most Valuable Participant (Moderator)

            What version of ID are you using?

            • 3. Re: Missing/Hidden fonts after creating a package
              sdumire Level 1

              We're using CS5...

              got it figured out! It was on Font Explorers side. They said that indesign will package everything just fine (which it's been doing!) it's just the fonts that are digitally protected that are packaged hidden/invisable. I think it may be something their working to fix cause when describing the issue to Font Explorer they knew what I was talking about and were quick to send me a work-around script called iShowFiles. So every time we package a project through indesign we have to take that project folder and drop it in the iShowFiles script and it will make the "missing" fonts visable.

              • 4. Re: Missing/Hidden fonts after creating a package

                Hey sdumire - thanks for posting here. My colleague and I ran into this exact same bug with FontExplorer only today, and you've saved us a lot of time troubleshooting.


                The following is the temporary solution we're using until Linotype actually resolves it:


                1. Create a folder on the desktop called Packaged


                2. Create a shell script called UnhidePackagedFonts.sh with the following contents:


                     #! /bin/sh

                     # This script 'unhides' packaged fonts hidden by Linotype FontExplorer Pro

                     chflags -R nohidden ~/Desktop/Packaged/


                3. Drop this shell script into the local script folder for an affected Studio operator - ie ~/Library/Scripts


                4. Launch Automator, create a new Folder Action called UnhidePackagedFonts and set the Folder Action receives files and folders option to the Packages folder you created on the desktop in Step 1.


                5. Add a Run Shell Script step per the Automator screenshot below, entering the path to the shell script you created in Step 2:



                6. Save the Folder Action, and quit Automator.


                Now when the studio operator packages a job, she can just export it to the Packages folder you created on the desktop. The previously hidden fonts will automatically 'appear' after a few seconds.


                Whilst this workaround does involve a few (very, very easy) steps, it has the advantage of not requiring the operator to manually drop the package onto a script after each package export from InDesign.

                • 5. Re: Missing/Hidden fonts after creating a package

                  No need for a folder action, using the tips from the link below. You can use the script directly in the automator… and save it as a service. Simply right click on a file or folder and run the service.



                  • 6. Re: Missing/Hidden fonts after creating a package

                    Open Terminal and run

                    cd /Users/Shared && rm -rf FontExplorer\ X\ Server && mv .FontExplorer\ X\ Server FontExplorer\ X\ Server


                    Problem solved.

                    • 7. Re: Missing/Hidden fonts after creating a package

                      @drinkonlyscotch How do you undo this?? It's made the collected Fonts folder disappear all together despite it being checked in 'Package'...