4 Replies Latest reply: Apr 17, 2012 7:20 AM by Arpit Kapoor RSS

    CS 5.5 Silent deployment Errors

    rosy#55 Community Member



      I have built a Silent deployment installer for CS 5.5 using "Adobe Application Manager Enterprise Edition".  The Core CS Application installs fine, but there is a problem with the Exception installs for Dreamweaver Widget Browser and Adobe Content Viewer.  When deployed, the deployment logs are coming back with the error "error code 7(The storage control blocks were destroyed)"


      I am using the command lines provided in the exceptions.txt file.  Everything I have found in Adobe support relating to en error code 7 has said to repair the Windows Installer.  This will not be the case here as my test environment are Windows 7 32-bit Base Image (clean state) computers with no other software installed.


      Any help would be greatly appreciated.



        • 1. Re: CS 5.5 Silent deployment Errors
          Jeff A Wright Adobe Employee

          Rosy#55 I would recommend running the Adobe Support Advisor - http://www.adobe.com/support/loganalyzer/ on one of the computers which is not allowing the software to install properly.  The ASA will review your installation logs and attempt to locate a solution.


          Also have you tried running the installer on the same computer without utilizing your deployment workflow?  This will help verify it is not an issue with the deployment setup.

          • 2. Re: CS 5.5 Silent deployment Errors
            Arpit Kapoor Adobe Employee

            Rosy#55, please go through the exact workflow for deploying the items in exceptions folder that is mentioned in the below deployment guide. It also contains the common errors that people get while deploying the applications.

            http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/devnet/creativesuite/pdfs/Ad obeApplicationManagerEnterpriseEditionDeploymentGuide_v2_1.pdf


            Also, Jeff pointed out a very important step, that try to manually install the application and check if its an issue with the install package that you have created using AAMEE or its an issue with the install files itself or may be with something else.


            Check the install.log file for the exact errors(c:\Program Files\CommonFiles\Adobe\Installers\[Adobe Application name<date>].log.gz).

            • 3. Re: CS 5.5 Silent deployment Errors
              rosy#55 Community Member



              Thanks for the responses.  Just a quick update as things have changed a bit. 


              I first tried the Adobe Support Advisor.  It only displayed 3 errors, all relating to RAW Camera etc for Photoshop.  The interesting thing is that solution in the KB articles relating to those errors say that I am trying to install CS 4 over CS5...which I'm not....anywho, that doesn't really matter right now.


              I had already used the deployment guide when I built the original package, but I went through it again to make sure I didn't miss anything.


              Long story short, I think I have narrowed it down to it NOT being a CS 5.5 issue, but an AIR issue instead.  I Re-imaged a computer to a clean state and deployed nothing but AIR to it (no CS 5).  I then tried to deploy the Widget Browser via sccm and it again gets the "Storage Blocks Were Destroyed" error in the SCCM logs.  I downloaded an updated version of AIR and fresh copy of WidgetBrowser.air and got the same result.


              I will continue on this sometime next week.  If there are further ideas that may help that would be great!





              • 4. Re: CS 5.5 Silent deployment Errors
                Arpit Kapoor Adobe Employee

                Rosy, you can go to page 67 of the above guide and try to test the package on a fresh machine and check, if the issue is with the deployment package you have created or not. If everything works fine there, then it means the package is fine but there are some issue while using SCCM to actually deploy the application. So, in that case you might need to get in touch with the SCCM folks and take their help to fix it.


                Hope that Helps!