3 Replies Latest reply: Apr 15, 2012 9:56 AM by TheMuayThaiKid RSS

    TTF to TTC Font Substitution Error

    TheMuayThaiKid

      Upon opening one particular .ai file on another computer, I keep having the same font substitution problem.  The file was created in CS4 on a Mac, using a TTC font family and the problem occurs in CS5 on a Windows 7 computer using the same font family, only as a set of TTFs instead of a TTC.  The font appears as Medium Condensed rather than Medium (although in the dropdown, it still says "Medium") and is messing everything up.

       

      So, I tried uninstalling and reinstalling the whole font family, then reopening... same problem.  I tried uninstalling ONLY the Medium Condensed TTF and leaving all the others installed and active, but then the text turns into a bunch of Gibberish.  I tried switching to Medium Condensed and then back to Medium from the dropdown menu, no change whatsoever.  I literally am at a total loss.

        • 1. Re: TTF to TTC Font Substitution Error
          Manish-Sharma Employee Hosts

          Untill and Unless the font type will not be same , it will not work

           

          Copy the font from another machine and install it on this machine and you will be good to go.

           

          TTF and TTC are two completly different font type , having completly different structure.

          • 2. Re: TTF to TTC Font Substitution Error
            Mike Gondek2 CommunityMVP

            There are more locations than the control panel for fonts.  Mac and windows are both nutty for having numerouslocations where fonts are loaded and foreign language fonts nobody used. I am more familiar with the mac OS so cannot name all the locations on WIN7.Here si one other:

             

            Untitled-1.jpg

             

            Clsoe all apps.

            Close any fonts you are not using.

            Delete C:\Windows\System32\FNTCACHE.DAT, and restart your system. This will clean out your font cache which has a font ID conflict.




            • 3. Re: TTF to TTC Font Substitution Error
              TheMuayThaiKid Community Member

              Thanks for the suggestion Mike! It was a good idea and I thought, when I saw it, that it would solve the problem.  But unfortunately, even after I deleted the font cache (FNTCACHE.DAT), the problem persists, so there's got to be something else causing the font issue