14 Replies Latest reply on Apr 23, 2012 9:45 AM by Bill Gehrke

    Mercury Acceleration not working with CUDA card hack despite CUDA card updates/ram/etc.

    asbissonnett Level 1

      I'll try and keep this brief, I have been at this for about 17 hours and think I have finally figured out my problem. I didn't find this info anywhere else, so I hope others may benefit from this.

       

      I was trying to enable CUDA and GPU acceleration in Premiere CS5.5 with my NVIDIA Quadro 5600 card. I realized it wasn't on the list of supported cards, but I came across the "hack" that many users were trying by adding the name of the card to the "cuda_supported_cards.txt" list.

       

      My machine specs:

      Mac Pro Early 2008

      2 x 3.2 GHz Quad-Core Intel Xeon

      NVIDIA Quadro FX 5600 1536 MB

      OS X Lion 10.7.3

      AJA Kona 3

       

      I made sure everything was up to date including CUDA drivers, NVIDIA drivers, Premiere, AJA drivers and everything. The NVIDIA site says that the Quadro 5600 cards supports CUDA also and the card has 1.5gb of ram. I thought it would be a breeze. So I ran the GPUsniffer, it said the card was CUDA enabled (more on this later).

       

      I went through the process and added "Quadro FX 5600" to the "cuda_supported_cards.txt" in Terminal.

       

      16 hours into the process, I excitedly opened Premiere to find that the Mercury Render setting was still unclickable and set to "software only" .

       

      I ran the GPUsniffer again and took a second look at the results:

       

      Texture memory: 0

      Vendor string:    NVIDIA Corporation

      Renderer string:  NVIDIA Quadro FX 5600 OpenGL Engine

      Version string:   2.1 NVIDIA-7.10.2

      OpenGL version as determined by Extensionator...

      OpenGL Version 2.0

      Supports shaders!

      Supports BGRA -> BGRA Shader

      Supports VUYA Shader -> BGRA

      Supports UYVY/YUYV ->BGRA Shader

      Supports YUV 4:2:0 -> BGRA Shader

      Testing for CUDA support...

         Found 1 devices supporting CUDA.

         CUDA Device # 0 properties -

         CUDA device details:

            Name: Quadro FX 5600

            Compute capability: 1.0

            Total Video Memory: 1535MB

         CUDA driver version: 4020

      CUDA Device # 0 not choosen because CUDA version 1.0 is not supported.

      Completed shader test!

      Internal return value: 7

       

      In the bold text, it says CUDA version 1.0 is not supported. This is very vague, to me at least (a video person, not a programmer). Since I had just updated the CUDA driver to 4.2.7, I know it couldn't be referring to that. The only other place in the text that "1.0" is mentioned is under "Compute Capability". So I went and found this page http://developer.nvidia.com/cuda-gpus where all the NVIDIA cards are listed along with their compute capability. Sure enough, one of the very few 1.0 cards on there is the Quadro FX 5600.

       

      I don't remember exactly where I read it, as I've been at this for about 19 hours now, but I found somewhere that Premiere only supports cards with a compute version of 1.1 (maybe 1.3) and higher.

       

      So my question is:

      Even though the "Quadro fx 5600" supports CUDA, and given the fact that many other cards have been unlocked using said "hack", Premiere can not be hacked to recognize the 5600 card because the card's "Compute Capability" is 1.0, is this correct?

      If so, is there any possible way to either make premiere recognize 1.0 cards, or update this useless $3000 card to 1.1 or 1.3?

       

      For reference here is a list of cards I pulled that also have the "Compute Capability 1.0". So users with these "Cuda enabled cards" might also have trouble:

       

      Tesla C870, D870, S870

      Quadro FX 4600, 5600

      GeForce 8800 Ultra, 8800 GTX, GT 420, GT 340, GT 330, GT 320, 315, 310, 9800 GT, 9600 GT, 9400GT

       

      Another question, maybe best for another thread - Is there any benefit/acceleration I could reap from my Kona3 card?