1 Reply Latest reply on Apr 23, 2012 2:02 PM by kokorito

    Debug mobile problem - adb server is out of date. killing...

    kokorito Level 4

      All of a sudden I cant connect FB to my phone to debug. It was literally all of a sudden, worked one day and then not the next and I'm not aware of doing anything.

       

      It started by not finding my phone unless I clicked refresh. It would then find it but with a warning that I need Android 2.2 to work (I have).

      I then get a warning that I need AIR 3.1.0.488 and would I like to install it. I have 3.2 from the android market.

       

      I then get the following error

       

      Error occurred while installing the application:

      adb server is out of date. killing...

      * daemon started successfully *

      ** daemon still not runningerror: cannot connect to daemon

       

      I have tried all sorts to no avail.

      I tried different workspaces and different projects

      I check FB for updates, but none

      I uninstalled and reinstalled FB (twice)

      I uninstalled AIR from my phone and let FB install 3.1, still no luck and trying again brings the same warning needing 3.1

      I tried installing the latest adb from the Android SDK, then copied it to the Flex SDK 4.6. Still no luck.

       

       

      If I run the app on device rather than debug then it works, but takes ages to start on the phone

      If I publish the app it will push it to the device, once again taking ages to complete.

      Once on the phone everything works ok.

       

      I'm at a loss now