14 Replies Latest reply on Sep 16, 2009 6:26 AM by Chris Deely

    Flex Builder will not start

    Ryfter1313 Level 1
      I really need some help on this. Flex builder will not start. When I try to run it, I get the error: An error has occured. See the log file: <has a location to file>.

      When I open the file, I get an error log. I will post it to the end of this message.

      So far, I have unisntalled/reinstalled Flex several times. I have uninstalled Java, and reinstalled Java. I have uninstalled Flex, removed ALL directories I could find (under /program files/ as well as /documents), run cclean to clear out registry entries, as well as going through the entries one at a time. I then rebooted, and reinstalled. I have also downloaded the original install file 3 times now.

      One oddity of my install, is that I am running on a re-directed desktop, so my /documents/flex builder 3/ directory is out on the network, but acts like it is locally mapped. I HAVE logged on my system's local account, which doesn't have a redirected desktop. This error occurs on both accounts.

      I am the administrator of this box, and all permissinos are run as an administrator. I am running Vista Business, and have run this both with user access control on and off. I have also tried running it in compatibility mode for Win XP SP2. While installing it seems to fail on the Cold Fusion plugin, but it continues to install, and tells me it installed fine. I am honestly at my wit's end on this one.

      Log File:
      !SESSION 2008-04-04 15:17:18.359 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.5.0_11
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.equinox.app 2008-04-04 15:17:22.589
      !MESSAGE Product com.adobe.flexbuilder.standalone.product could not be found.

      !ENTRY org.eclipse.osgi 4 0 2008-04-04 15:17:22.661
      !MESSAGE Application error
      !STACK 1
      java.lang.RuntimeException: No application id has been found.
      at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer. java:236)
      at org.eclipse.equinox.internal.app.EclipseAppContainer.start(EclipseAppContainer.java:98)
      at org.eclipse.equinox.internal.app.Activator.addingService(Activator.java:112)
      at org.osgi.util.tracker.ServiceTracker$Tracked.trackAdding(ServiceTracker.java:1064)
      at org.osgi.util.tracker.ServiceTracker$Tracked.trackInitialServices(ServiceTracker.java:926 )
      at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:330)
      at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:274)
      at org.eclipse.equinox.internal.app.Activator.start(Activator.java:54)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:9 99)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextIm pl.java:993)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:9 74)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
      at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
      at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLa zyStarter.java:111)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java :417)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoade r.java:189)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:34 0)
      at org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackag e.java:37)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java :405)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.jav a:83)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClassInternal(Unknown Source)
      at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.j ava:47)
      at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:9 99)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextIm pl.java:993)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:9 74)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
      at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManage r.java:634)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java :508)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelMana ger.java:282)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManage r.java:468)
      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)

      !ENTRY org.eclipse.osgi 2 0 2008-04-04 15:17:23.442
      !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2008-04-04 15:17:23.442
      !MESSAGE Bundle update@plugins/org.eclipse.datatools.connectivity.oda.template.ui_3.0.4.200706071.jar was not resolved.
      !SUBENTRY 2 org.eclipse.datatools.connectivity.oda.template.ui 2 0 2008-04-04 15:17:23.442
      !MESSAGE Missing required bundle org.eclipse.pde.ui_[3.2.0,4.0.0).

      !ENTRY org.eclipse.osgi 2 0 2008-04-04 15:17:23.497
      !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2008-04-04 15:17:23.497
      !MESSAGE Bundle update@plugins/org.eclipse.datatools.connectivity.oda.template.ui_3.0.4.200706071.jar [52] was not resolved.
      !SUBENTRY 2 org.eclipse.datatools.connectivity.oda.template.ui 2 0 2008-04-04 15:17:23.497
      !MESSAGE Missing required bundle org.eclipse.pde.ui_[3.2.0,4.0.0).
        • 1. Re: Flex Builder will not start
          Ryfter1313 Level 1
          So, no one has seen this problem before? It is extremely frustrating.
          • 2. Re: Flex Builder will not start
            Ryfter1313 Level 1
            I am still fighting this issue. I can NOT figure out why flex builder would fail like this. Any help would be GREATLY appreciated.
            • 3. Re: Flex Builder will not start
              Gaurav J Adobe Employee
              Can you try starting flex builder from command line using the -clean option?

              using the command prompt go to C:\Program Files\Adobe\Flex Builder 3

              and run flexbuilder.exe -clean

              You may also try to use a new workspace.

              Let me know if it doesn't resolve.

              Thanks,
              Gaurav
              • 4. Re: Flex Builder will not start
                Ryfter1313 Level 1
                Hello Gaurav,

                Thank you for your response. Running -clean did not resolve. I am not sure what you mean about using a new workspace. I HAVE logged on as another user, and it did not work under that Vista account, either.
                • 5. Re: Flex Builder will not start
                  Gaurav J Adobe Employee
                  Are you installing standalone version or plugin?

                  Can you please log a bug at http://bugs.adobe.com/flex

                  • 6. Re: Flex Builder will not start
                    Ryfter1313 Level 1
                    I am using the stand-alone version. I do not have Eclipse installed. I use dreamweaver for CF development. I will log a bug, now.
                    • 7. Re: Flex Builder will not start
                      GennadyK Level 2
                      This is an issue with weak Adobe installer that doesn't have required logic to verify your current java RTE settings.
                      If you uninstall Flex and java RTE from Add-Remove Programs then clean Path environment variable from traces of java plus delete JAVA_HOME and CLASSPATH. Then after restart and following installation of Flex Builder it will start.
                      • 8. Re: Flex Builder will not start
                        Ryfter1313 Level 1
                        quote:

                        Originally posted by: GennadyK
                        This is an issue with weak Adobe installer that doesn't have required logic to verify your current java RTE settings.
                        If you uninstall Flex and java RTE from Add-Remove Programs then clean Path environment variable from traces of java plus delete JAVA_HOME and CLASSPATH. Then after restart and following installation of Flex Builder it will start.


                        This did not seem to work. I uninstalled Flex, then I uninstalled Java. I went into environmental variables, and did not see JAVA_HOME or CLASSPATH. I also did not see any entries in the path statement. I rebooted, reinstalled FB3, and same issue. Though, after just reinstalling FB3, I did not see any changes in my path or syst variables. Thank you very much for the help.
                        • 9. Flex Builder will not start
                          GennadyK Level 2
                          It worked for me after I found somewhere Eclipse and java problem. I also did check registry for java entries.
                          Even no changes in path or environment variables I got Flex builder 3 running (with options only Flash 9 for both browsers):
                          INSTALL_FLASH9_OCX=1
                          INSTALL_NETSCAPE_PLUGIN=1
                          INSTALL_COLDFUSION_EXTENSIONS=0
                          INSTALL_JSECLIPSE=0
                          I'm sorry that it doesn't help in your case. Also you may try google on Eclipse and Vista issues. My OS is XP Pro.
                          • 10. Re: Flex Builder will not start
                            Ryfter1313 Level 1
                            Ok, this has FINALLY been fixed. There seems to be an issue with having your documents stored remotely. My documents folder, instead of being on my C: drive, has been redirected to the server, so the location is: \\server\share\username\documents\etc

                            To fix this, I uninstalled Flex Builder 3, then deleted that directory i makes under documents. I then logged off my account, and logged on as the local administrator. I installed as the local administrator which does not have a redirected desktop nor redirected documents folder. It installed fine. I logged off the local admin account, and logged in as my account, and was able to fire up Flex Builder 3. Though, it STILL created it's own "copy" of Documents on the network drive. So, the directory structure is \\server\share\userID\Documents, the problem, is that there are TWO "Documents" directories there. If you go to properties, windows still recognized the old one, as "My Documents" even though it is redirected as the file, Documents. The new folder, is also called Documents.

                            Odd behavior. Just hope this helps someone else, in the future.
                            • 11. Re: Flex Builder will not start
                              __Jerry__ Level 1
                              I found an easier fix. And which doesn't require a local login.

                              1. Install Flex as normal, you most likely already did otherwise your not here to look for answers :)
                              2. Goto the Flex directory, and change the configuration/config.ini file. There are two references to the directory @user.home. Change this to the drive map of the @user.home ( if they don't exist you have to make the drive mapping )
                              3. Reinstall Flex, it will prompt if you want to overwrite some the old file. Click No for the config file and Yes for the rest ( after you get the prompt for the config file, you can click Yes for all )
                              4. Done.
                              1 person found this helpful
                              • 12. Re: Flex Builder will not start
                                Ryfter1313 Level 1
                                Thank you VERY much for that response! VERY timely, since my boss was reinstalling Flex today. :-)
                                • 13. Re: Flex Builder will not start
                                  psha2000 Level 1
                                  Hello,

                                  I am having the same problem ... I am trying to change the @user.home in the config file to list the drive map but I get an error ... saying Cannot Create the C:\Program Files\Adobe\Flex Builder 3\configuration\config.ini file. Make sure that the path and file are correct. Now, I know they path is correct because that is where I opened the file from ... I am using Virtual Machine ... please let me know if there is a way around this problem ... I tried to right click and open the file using Run As Administrator option but that option is not available for single files .. it is available for exe and other program files ... my next plan is to try the solution by Ryfter1313 if this error is not resolved ... thank you
                                  • 14. Re: Flex Builder will not start
                                    Chris Deely Level 1

                                    I found that this was simply a corruption of my "Flex Builder 3" directory under My Documents.  I recently switched to a new computer with a fresh install of FB3.  I had carried over my "My Docs" from my old system, not realizing that the old FB3 directory would cause issues with the fresh install.

                                     

                                    I renamed the "Flash Builder 3" folder to "Flash Builder 3 backup" and ran FB3 again.  On startup, FB3 created a new "Flash Builder 3" directory and all is well!