2 Replies Latest reply on Dec 14, 2012 6:38 AM by MichelBParis

    PSE9 backup and restore not compatible


      OK, My computer was acting up, it picked up some Malware I was unable to get rid of, so I decided to wipe my hard drive and start fresh (Nuked it).  Well I have photoshop elements 9 and I spent countless hours setting up tags and facial recognition and stuff on my thousands of photos.  I didn't want to loose that, so I ran backup to external hard drive from PSE9.  I got no errors, the backup worked like a charm, so it seemed.  When I got my computer up and running again, I went to restore from hard drive and it specificaly looked a tally file (*.tly).  That file wasn't created anywhere in the directory where the photoshop restore was saved.  ALL my photos are in that directory, as well as thousands of xml files but no tly files.  So I can't restore the photos to their original location, with names, and most importantly, tags.  Why are the backup and restore features not consistent in their implementation and is there any way to restore the fiels now?  Aside from the hard way that is.


      I am sorry if this question has been asked in another forum, I'm not blog and forum savy enough to find the answer if it has already been asked.  I searched for the keywords tally and tly and couldn't find any so I'm assuming this has not been asked.  Please help.





      Supplimental data:

      Windows 7, 64 bit system.

        • 1. Re: PSE9 backup and restore not compatible
          andaleebfatima1 Adobe Employee

          May be needless to reply now.. but the tly file should be there. Sometimes it doesn' show up unless you click the "Media types" dropdown on the Restore dialog or may be type Backup.tly in the File name/path textfield.




          • 2. Re: PSE9 backup and restore not compatible
            MichelBParis Adobe Community Professional & MVP

            Engineer1279 wrote:


            . .. I got no errors, the backup worked like a charm, so it seemed. 

            Yes, that's the problem. It's not uncommon that the backup seems to be complete and ok... but the .tly file is not yet written in the backup folder.

            There is a time lag at the end of the backup when no message is displayed and many users stop the process prematurely. Or for some other unknown reason, the backup is not complete. The last files to be written in the backup folder are catalog.buc, then backup.tly. So my advice would be to always have a look after the backup to see if the .tly is present in the backup folder. That does not guarantee you won't have other problems in the restore.

            For information, the catalog.buc is a copy of the present database catalog.pse11db, where the full paths of each file is kept. Each media (or xmp) file is copied and renamed B0000001.xxx so that there is no risk of duplicates and in a very short file copy name. The backup.tly is a list telling which file copy name is linked with each internal identifier for that file. You understand why it is absolutely necessary.