6 Replies Latest reply on May 14, 2014 12:53 AM by Vijay_Gupta

    AcroQTP works with Reader 10.1.1, not 10.1.2 nor 10.1.3

    Brent_2310242 Level 1

      Hi all,


      I have a suite of AcroQTP scripts written against Reader 9 that I was keen on porting to Reader X. I've seen a lot of frustrated users complaining about AcroQTP not working with their version of Reader X.  I was going to add my voice to the frustration.  In my case, what I was seeing was:

      0. Unregister any previous AcroQTP and uninstall any previous Reader.

      1. Install Reader 10.1.3

      2. Register the AcroQTP plugin

      3. Start QTP

      4. Start Reader (manually)

      5. Open my form (manually)

      Reader crashes!  (... and it would only crash if QTP were running.)

      (6. If I could, I would run QTP's Object Spy to see if it detects AcroField objects on my form.  But when your Reader crashes, you're not off to a good start.)


      I tried many uninstalls and reinstalls to try to get this to work, with no success. Then on a whim, I downloaded the Reader 10.1.1 installer from a third-party archival website, since it was no longer available from Adobe.  I installed it, followed the same steps as above... and voila, Object Spy WORKED!


      I've tried this on Win XP SP3 and Windows 7, and Object Spy worked in both cases.  After a little tweaking, my regression suite is now ticking along against Reader X. 


      So until Adobe addresses their issue, all you have to do is find a source for the Adobe Reader 10.1.1 installer that you trust.  Something like this, from http://www.filehippo.com/download_adobe_reader/tech/10591/

      Title:Adobe Reader 10.1.1
      File size:50.24MB (52,677,528 bytes)
      MD5 Checksum:72E7C5531A20556AAFA5F31978FA1105


      Happy trails,