1 Reply Latest reply on Apr 22, 2008 2:44 PM by marbolor

    Web Service Timeout over HTTP

    jukee Level 1
      I am experiencing a timeout when performing a long data call via a web service across HTTP. It seems to happen after 30 seconds of inactivity. I have set the requestTimeout="0" and it still does not work. If I change my channel to point towards rtmp:2037 all is fine, but would like to only use port 80.

      I have seen cached pages about this problem in the old Apollo forums, but no solution and they did not seem to migrate here. Am I the only one currently experiencing this problem? By the way, I see the same behavior using both Fluorine and Weborb, Blaze is not an option.

      Here is the fault I receive:

      Channel.Call.Failed
      NetConnection.Call.Failed: HTTP: Failed


        • 1. Re: Web Service Timeout over HTTP
          marbolor
          Hi,

          I got the same problem.
          In php, we excute an engine(.exe) to process the data, the processing time will be a couple of hours because the data is very huge.

          But we got the same error message after one hour. We already extend all timer like php execution time to 100 hrs, in IIS all the timer extend to 24 hrs, in flex for calling the remote object, we set "0" for unlimitation, but still got the error message. It is one hour but sometimes around 55 mins.

          We are not sure the problem is coming from weborb or flex remote object, looks like the connection is broken, stop after one hour. We also tried to sleep in php more than one hour but got the message after one hour. So we guess it can not be stayed in php more than one hour.

          The error message is the same:
          Channel.Call.Failed
          NetConnection.Call.Failed: HTTP: Failed

          Anyone has the same problem?