10 Replies Latest reply on May 25, 2012 4:12 AM by Peter Grainge

    Tables all jumbled up

    Colette M. Level 1

      Publsihing WebHelp using RoboHelp 8.0.2.08.

       

      My team has encountered issues with tables getting all jumbled up and we're hoping someone can tell us what's going on and provide some suggestions of how to troubleshoot.  This has occured on  multiple computers, publishing different projects, publishing to different servers. It appears after generating.  In each project, we provide several topics that are lists of links to various topics. The information is presented in a table with a column for title, a column for doc number and a table for date.  At random times, seemingly after we add or update links, the table rows and columns get messed up.  A linked title suddenly appears in the doc number column for another document and several rows of links just disappear.  We've tried deleting the CPD and reimporting a "clean" htm file from a previous backup but when we do that, the links come in all broken - this seems to happen on these pages only as other imported htm files with links come in just fine.  I've attached a screen shot showing various examples.  Any suggestions would be greatly appreciated.

       

      Thanks - Colette

       

      WebHelp table issue.png

        • 1. Re: Tables all jumbled up
          Amebr Level 4

          Perhaps a screenshot of a relevent section in RH might help, so we can see the table structure itself? I wonder if maybe there are merged cells or rows being used?

          • 2. Re: Tables all jumbled up
            Colette M. Level 1

            Even after several weeks of continued troubleshooting, we're still having this issue on multiple systems, primarily the same project but we have seen it on another project as well on a different system.  The problem is getting progressively worse. It seems that if we add a row to a table and hyperlink to a topic, the table usually gets jumbled.  Sometimes it seems to insert some random tag that means nothing and that we have not added. Other times, the columns seem to shift.  So far, it only seems to occur with tables that contain links to other topics.  The tables are basic tables that we've used for years in this project. We thought we were on to something when we discovered that the users was dragging and dropping a topic from the topic list into the table to create the link but it happens just as often if the link is manually typed and linked. I've attached screen shots of a correct view of the table published to WebHelp, a jumbled up table and the HTML code.  I would appreciate any input as we are at a dead stop and cannot publish until this is resolved (and we publish updates daily )  Thanks - Colette

            Correct.pngjumbled up.pngHTML code.png

            • 3. Re: Tables all jumbled up
              Amebr Level 4

              Well, the content is not in a table, hence the incorrect display. It is displaying correctly as per the code in the page.

               

              I also have no idea what the <u> tag is.

               

              Is the code you posted taken from the Robohelp topic, or  from the webhelp output? If its the webhelp output, then seeing the code from within Robohelp might shed some light. If possible a snippet when it is correct in Robohelp and a snippet after it is broken.

               

              Amber

              • 4. Re: Tables all jumbled up
                Colette M. Level 1

                All of the screen shots came from within RoboHelp and not the published output. The problem never appears at the point where we add a row, which seems strange. So far, we've only had this happen to tables that include hyperlinks to other RH topics. We use a lot of step action tables - at least 50% of our topics include them and yet it's only the tables that are lists of hyperlinks that have exhibited this issue.  We're totally stumped and nearly at a stand still because of this issue - it took all day to publish two basic topics due to all the rework and stopping to backup after adding or updating every new document.  We work from local copies and these topics have been in use for years as I mentioned before and only in the past couple of months have we had this issue. It used to be maybe once every couple of week this would occur but now it's all day long. 

                • 5. Re: Tables all jumbled up
                  Colette M. Level 1

                  Sorry - forgot to add a screen shot of the code when it's working correctly.  This is the same page, same section. Thanks - Colette

                  HTML code.png

                  • 6. Re: Tables all jumbled up
                    Peter Grainge Adobe Community Professional (Moderator)

                    It doesn't help here that the posts are solid blocks of text rather than properly laid out to assist anyone trying to help. Sorry but has to be said.

                     

                    Something is wrong with the code. As Amebr pointed out, there is a <u> tag and I'm not aware of any such tag. <ul> is for an unordered list (bullet points) but what is your <u> style?

                     

                    The <pn> tag in red is also some unusual code.

                     

                    It feels like this problem is somehow related to how you are working. Do you do all the editing in RoboHelp or are you lifting content from somewhere else. Is anyone going into the code to do some editing?

                     

                    How are you adding rows? How are you creating links.

                     

                    The CPD will make no difference to this problem. It is related to your HTML and CSS. If you import a good topic and a bad topic into a new project, is the bad topic still a bad topic? That is, is the table still messed up?

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                    @petergrainge

                    • 7. Re: Tables all jumbled up
                      robopenguin

                      As Peter says, the <pn;"> code is weird. I'd also guess that that is the result of authoring outside of RoboHelp or manually editing the HTML code.

                       

                      Are you using version control? If so, maybe the strange code is a result of a source control system merging two versions of an HTML file?

                       

                      For what it's worth, the <U> tag can be used to underline text. It is deprecated HTML code but still supported by browsers (and the RoboHelp HTML editor).

                       

                      Dave

                      • 8. Re: Tables all jumbled up
                        Colette M. Level 1

                        I agree, the <pn;"> code is weird.  We rarely touch the HTML code other than view it to see what's going on so and this code just suddenly appeared in the middle of the document.  The only scripts we have in our docs  are applied in the master pages and those are very few.

                         

                        We are not using version control and have only one person adminstering the project.

                         

                        We publish documents that are authored by others (many others) so authoring in RH is not an option.  They all use Word templates we created for them that align with our RH styles.

                         

                        We add rows by right clicking on a row and inserting a row above or below.  If we need to add a row to the bottom of a table, we just use the enter or tab keys.

                         

                        This seems to happen only on the pages where we provide links to multiple topics within  RH, something we've done within all of our projects since 2007.  Links outside of tables don't present any issues.

                         

                        The other strange thing is that we don't even have to "do" anything to that topic. Sometimes the tables get jumbled up when we just open and view them in RH.

                         

                        We've been trying to figure out what might have changed since our process has not changed. At first we thought it might be because IT pushes out new/updated software from time to time but this has not impacted other projects in RH. We have a pretty strong anti-virus software installed so we feel confident that it is not virus-related.

                         

                        This project is managed by the team's most experienced person and after significant evaluation, her work habits are the same as her team mates. We're stumped and just trying to figure out if there is something external to RH that we can investigate that might be causing these issues. 

                        Colette

                        • 9. Re: Tables all jumbled up
                          Amebr Level 4

                          Ah importing from Word is a completely different ball game and I can't really help there as I've never worked that way.

                           

                          However, as I pointed out earlier, the code you posted is not using tables. So all I can assume is there is a css at the top of the topic forcing non-table styles to look like a table, and this css is getting deleted/corrupted somehow.

                           

                          Perhaps someone who imports Word docs is watching and can help.

                          • 10. Re: Tables all jumbled up
                            Peter Grainge Adobe Community Professional (Moderator)

                            As Amber has pointed out twice, it does look as if some of the content is not actually in a table but it's not easy to help on this one without actually seeing the code for a whole topic.

                             

                            If you can share one topic, please import it into a new project using the same CSS as in the live project. The topic shown in the very first screenshot would be good as then this thread details the issues. Zip that up and send as instructed on the Contact page of my site.

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                             

                            @petergrainge