8 Replies Latest reply on Apr 8, 2008 12:01 PM by HKabaker

    Links

    Davilam Level 1
      I am working in RoboHelp v6 w/ WebHelp as my primary layout. I am currently trying to create a link from one topic to another topic in the help system. For some reason I am receiving an error which states "This action will create an external link to the help system. The link may not function when the help system is moved to other systems." Any idea why i am receiving this error? I have established many links between topics and this has not been an issue in the past.

      Thanks
        • 1. Re: Links
          HKabaker Level 2
          For some reason, RH doesn't recognize the filename or title of the target topic.

          1. Did you create the topic in RH?
          2. Did you create the TOC and, later, change the topic title or and/or filename?
          3. Did you move the target topic into another RH folder after creating the TOC?

          When you view properties of the TOC entry, do you see the correct title and location in the dropdown list and in the link field at the top?

          Harvey
          • 2. Re: Links
            Captiv8r Adobe Community Professional & MVP
            Hi Davilam

            How exactly are you creating the link? Dragging from one place to another? Using dialogs?

            Cheers... Rick
            • 3. Re: Links
              Davilam Level 1
              Thanks for the response HKabaker.
              1. Yes the topic was created in RH
              2. No.
              3. No

              Yes I see the correct titel and location in the dropdown list.

              Thanks,
              Dave
              • 4. Re: Links
                Davilam Level 1
                Rick, I am highlighting the text i want to create the link with, right clicking, selecting insert hyperlink, then selecting the topic i wish to link to from the dropdown list.

                Thanks,
                Dave
                • 5. Re: Links
                  HKabaker Level 2
                  Dave,

                  Are there any usual characters in the filename or topic title?

                  Underscore _ and hyphen - are OK; any others invite trouble on several fronts.

                  Harvey
                  • 6. Re: Links
                    Davilam Level 1
                    Nothing more than an Underscore :(
                    • 7. Re: Links
                      RoboColum(n) Level 5
                      Is the file you are linking to accessible from the TOC or index? If so, does it open OK from there?
                      • 8. Re: Links
                        HKabaker Level 2
                        Sometimes this will straighten out a link problem:

                        From the TOC entry's Properties dialog, select a different topic. Save the change, save the project.

                        Reopen the properties dialog, select the original topic and save the change.

                        OK now?

                        Harvey