7 Replies Latest reply on Sep 24, 2016 5:34 AM by Willam van Weelden

    Search not Working in Webhelp or Webhelp Pro


      I am currently running Adobe Robohelp version 10.  I have several different RH files that I manage (desk procedures) and in each of the ones that I manage, my latest publishings have broken search functions.  What I mean by broke: it will search some words just fine, but others that I know are in my desk procedures show "no topics found".   Some of my files are published using webhelp and some webhelp pro, with the same problem.

      I have done the following:

      1) Gone back to a backed up file dated 05/01/2014 (that the search seems to be working just fine in) and done edits to it, published and it breaks the search.

      2) I have gone back to the working 05/01/2014 file and done nothing to it except publish it and it breaks.

      3) Checked the button to clear the cache

      4) From Webhelp Settings Option I have:

      ·         Changed output folder that it publishes to (which is on a local drive before I transfer it to the network drive)

      ·         I have enabled substring search (which actually does allow it to render some results, but not all the results it should)

      ·         Tried to click “Republish All” setting

      5) Created new (not duplicate) webhelp layout

      6) Checked that language is set to English (US)

      7) Ensured that the words that I know aren’t searching aren’t included in the ignore and stop list.

      8) Tried switching from DHTML > Pure HTML to just Pure HTML

      9) I noticed that the Output view generates the following message :

                      Processing Full-text-search data...

      Finished processing Full-Text-Search data in 0 sec(s)

      10) Deleted the “webhelp” file from the !SSL! folder and then republished it

      11) The biggest finds that I have are the following:

      ·         That publishing the file is what seems to break the search functionality

      ·         When the file is published a few of the files in the !SSL! folder are substantially smaller than they were in the working file:

      o   WHXDATA

      o   WHGDATA


      Any help with this problem would be greatly appreciated.


      Thanks, Shannon